Home        Store        Docs        Blog

Ping360 connection problem

Hello,

I have both ping altimeter and sonar plugged in. Works if Iplug directly to my computer but through the ROV they are not detcted.

Do I need to setup routing for them?

Note that I am using the module load DepthOutput hack and my comms in QGC is difrent:



Cheers,
E

Update:

Just wanted to share the pig1 and ping360 working together inside my tote tand:

Hello @etienne,

Our Ping360 routing implementation is currently not the same used for the routing page. Due to performance/latency issues, we implemented a dedicated service for it.
We recently released a 0.0.18 version of the companion with it, which should make it plug and play.

1 Like

I cannot get either Ping sonar sensors to work. Either through the ROV, or connected directly to the PC with USB. I tried version Ping Viewer t.2.0.3, and t.2.0.4.
They both show up as comm ports on the PC in Device Manager.
When running through the companion (v 0.18) they show on the system screen (port 2770).

Firewall on PC disabled.

No devices detected in Ping Viewer.

What am I doing wrong?

Correction: I can get the devices to work when connected to the PC through USB. Nothing when connected to the ROV through the normal way.

???

Hello,
Can you show us a print-screen for your companion system page with the screen sessions and usb devices?

Hi William,
This is what the System screen looks like:

The companion computer remind me to update to 0.0.18,but the update online is too slow and unstable .I prefer to remove SD card and update it directly.But I can not find the package about 0.0.18.Can you give a link or update it on Ardusub.com. I brought the P360 recently last week.

Here is the download link: https://s3.amazonaws.com/downloads.bluerobotics.com/Pi/stable/ardusub-raspbian.img.zip

I’m interested to here if you get your P360 running.

Hi guys,
I just re-read your request. I’m not sure what you mean by ‘screen sessions’?
I still can’t get either ping units to show up on the topside PC through the companion RPi.

Hello @k-deboer and @MMMMK , it’s not clear yet what the problem is and we are struggling to get complete information in this thread. Please email support@bluerobotics.com, and you can arrange an appointment with me for direct technical support.

To use ping360 with the BlueROV2 you MUST:

It appears that @k-deboer had not rebooted companion after the update. The ping360 will not be detected until after reboot.