Home        Store        Docs        Blog

No connection through RPI3 after firmware update

Hello.
I added a custom frame to the ardusub code and then I built it. All seem well and no errors were reported. I uploaded the .apj file to the pixhawk1. All seem to have gone well here too, no errors. This all worked through the RPI.

Now to the problem. After uploading the new firmware I can no longer connect to it via the RPI (ethernet) as I could before. I do get the video from the RPI, but no connection to the AP. However, I can connect directly via USB to PC. This works as it did before.

I’ve changed the firmware again to the latest stable version. The problem still persists. Any idea what I can to do solve this issue?

I get these messages after running dmesg -w after disconnecting and connecting the pixhawk usb:

[ 570.822166] usb 1-1.2: USB disconnect, device number 5

[ 578.797660] usb 1-1.2: new full-speed USB device number 6 using dwc_otg

[ 578.940186] usb 1-1.2: New USB device found, idVendor=0483, idProduct=5740

[ 578.940204] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber

=3

[ 578.940212] usb 1-1.2: Product: Pixhawk1

[ 578.940220] usb 1-1.2: Manufacturer: ArduPilot

[ 578.940228] usb 1-1.2: SerialNumber: 2D0019000E51373137353433

[ 578.943552] cdc_acm 1-1.2:1.0: ttyACM0: USB ACM device

The issue got solved by re-flashing the raspberry pi.