New BlueROV2, Ping Connection Issue

I’ve just set up my new BlueROV2 with Ping Altimeter. I have the R4 version with the Navigator flight controller and the recommended Lithium-ion Battery (14.8V, 15.6Ah) battery. I am using the latest stable ArduSub and BlueOS versions.

When we connect the ping altimeter to the vehicle (following the Ping Setup guide) and open QGroundControl the vehicle connects and we receive telemetry but we do not receive the camera feed. When we disconnect the Ping altimeter we do receive camera feed and the everything works as expected.

The next thing we did was try connecting the Ping altimeter directly to our laptop. We downloaded Ping Viewer and open the application but it never discovers the device. We tried this on mac, linux, and windows machines.

We also tried a different micro USB-USB A cable. The first USB cable that we were using was a power only but the second one we tried we confirmed is data and power. Based on the trouble shooting I’ve described I’m hoping to get some suggestions on what to try next, or if it is fair to say that the Ping device is faulty.

Hi @dben45, welcome to the forum :slight_smile:

Sorry to hear you’re having issues getting your Ping Sonar connected.

That’s potentially concerning, and points to some kind of hardware/electrical issue. It may be drawing too much power for your supply, although given you’re using a recent BlueROV2 that shouldn’t be the case with a properly working sensor.

There are still a few things to try in our troubleshooting page; in particular

  1. confirming that the USB to serial converter is working (for our BLUART:
    • green PWR LED turns on when plugged in to computer,
    • FTDI FT231X USB UART device shows up in the connected USB/serial devices list,
    • has occasional flashes of the green TX LED when Ping Viewer is searching for a Ping device)
  2. making sure the wires are connected correctly, and
  3. trying the device recovery procedure.

If those don’t help, please contact to let them know what’s going on, and sort out a replacement or refund as appropriate. If you do so, please include your order number (/ estimated order date) and a link to this thread :slight_smile:

Hi @EliotBR thanks for the suggestions.

  1. Regarding confirmation that the USB to serial converter is working:
  • The PWR LED is lit up yellow when plugged into computer. It’s yellowish green but definitely more yellow than the TX LED which is clearly green.
  • FTDI FT231X USB UART device does show up in the connected device list.
  • When Ping Viewer is searching for the Ping device, the TX LED is solid green, not flashing. When I close Ping viewer and keep the sensor plugged in the green TX LED stays lit up solid.
  1. Double checked that the wires are connected correctly and tried switching RX and TX.

  2. Regarding the device recovery proceeder, I did open up the device and confirmed the LED is blinking. In this case according to the attached page, device recovery is not necessary.

That being said, if there is anything else you can recommend trying it would be greatly appreciated. Otherwise I will reach out to Blue Robotics Support.

Thanks again,

The USB UART device when connected to computer and Ping Viewer is searching for device.

Yeah, as LEDs go that still falls within the realm of ones that are sold as “green”, but the TX one is a deeper and purer green which does complicate things a bit when discussing the colours. The power LED has no colour shifting ability, so if it’s lit up then it’s confirming that power is being detected.

Ok, so communication of the BLUART with the computer seems to be working.

That’s interesting. When I have mine plugged in it does some flashes between TX and RX, and if I unplug the sonar then just the TX LED flashes occasionally as Ping Viewer polls it to see if it’s a potential Ping device.

I’m not sure what would reasonably cause it to stay on, because the computer shouldn’t have a reason to continuously transmit anything. That LED is controlled by the chip on the BLUART, so it should only be turning on when it believes it’s receiving communication from the computer.

  • is the TX LED on even when Ping Viewer is closed?
    • if so, there may be something wrong with your BLUART, or some other program on your computer that’s trying to talk serial
  • is the RX LED on/flashing at all, or just TX?

Fair enough.

  • Can you try updating BlueOS to the latest beta release, and then connecting the Ping to serial port 3 on the Navigator (some more details here), bypassing the BLUART?
    • there’s a new Vehicle/Pings page (in recent BlueOS beta releases), where a listing for the sonar should appear if it’s detected
    • if that doesn’t work then there’s most likely something wrong with your sonar - please contact the support email

The TX LED is on even when the Ping Viewer is closed. The RX LED is never on or flashing.

Regarding updating BlueOS to the latest beta release - will I need to flash a new SD card with the latest beta release or is there a way to update BlueOS in blueos-frontend? I am already on the latest stable release and don’t have an option to upgrade to the latest beta release in blueos-frontend.

Thanks again

Ok, I expect there’s some issue with your BLUART, or possibly your USB cable. If possible I’d recommend trying another cable to see whether it has the same behaviour with the LED, and if so please contact the support email to sort out a replacement BLUART.

You’ll need to turn on Pirate Mode to update to non-stable BlueOS releases, but there’s no need to flash the SD card again, and you can switch back to a previously installed release whenever you want :slight_smile:

Hi Elliot,

I followed the link above to turn on pirate mode and updated BlueOS to 1.1.0-beta.10. I followed the instructions on the thread you linked to connect the Ping directly to Serial 3 on the navigator board. Under the Pings tab in BlueOS it says “No Ping devices available.” I am in touch with customer support so will work with them to get the Ping device replaced. Thanks for your help.

1 Like

Hi @EliotBR just following up with this. We got our replacement Ping Altimeter and it is working as it should. Thanks for your help!