BlueOS won't detect Ping1D


BlueOS doesn’t find my Ping1D, and I can’t figure out why.
The Ping works well with Ping Viewer over serial, only using manual configuration though, not sure if it should be detected automatically?
Ping Viewer sometimes report the correct FW and device No. of the ping, and sometimes just 0, this seems suspicious to me. It still works and I can see the ping responses, but reports FW as 0.0.

Restarting Ping viewer sometimes it reports firmware and device.

If I try to downgrade to a previous FW I just get an error.

In the ROV it’s connected to a raspberry pi 4 using a bluart adapter.
When the bluart is connected to the raspberry it shows up as ttyUSB0.
When I relaunch the ping service I can see the service probing the port of the ping, but returning nothing.

The ping is running FW 3.29. I used ping viewer 2.4.1 and blueos is 1.1.0-beta.22.

Any ideas or suggestions how to resolve this would be greatly appreciated!


1 Like

Yes it should detect automatically, can you provide the GUI log of ping-viewer attempting to connect with it ?

Downgrade the firmware should not be necessary, and I would not recommend. But, the error is interesting, the operation should not fail.

Since Ping Viewer, stm32flash and BlueOS are failing to communicate with Ping correctly. Right now I’m suspicious about bluart.

Please provide the log of ping-viewer as requested and, if you are running the latest BlueOS (beta.27), provide the log of it as well.

Sure. Here are some. The bluart is on COM4. The first one I think was successful, since the log shows it’s handling messages. The last one is one where it connects successfully (with manual config) but the FW flashing fails.

20230722-024222280.txt (363.9 KB)
20230722-024500115.txt (20.5 KB)
20230722-024517068.txt (24.4 KB)
20230722-024545262.txt (60.5 KB)

I forgot to write I have tried with two different bluarts (both new and previously unused). I also tried two different computers, a desktop running win11 and a laptop running win 10, both running the newest ping viewer.
With the laptop I have tried both running on battery only and with charger connected. I have also tested various micro usb cables, but the main one I used is a very high quality cable that has never been an issue before. For good measure I also tried a new MicroConnect cable and I verified the cable work to program a Teensy.

Looking at the code of blueos,, it seems to me that the ping1d is not answering as expected. It expects, at the very least, the ping to answer with it’s fw version. If that fails it will just return None. But we have seen with pingviewer that it does not always report it’s fw version correctly. Is ping viewers auto detection doing the same and this might be the reason why it doesn’t find it? With a manual connection pingviewer can talk to and trigger the ping1d even if it doesn’t get a valid fw version.

Also, about the legacy device mentioned here, could my ping count as legacy as it’s not a ping 2, or should 3.29 already use the new format?

On a separate note. I’m not very good at python, but I think there is a bug in
I don’t think it ever tests the legacy case.
I had to comment out these two lines to get it to run the legacy test.

After doing some tests with Carl, we end up verifying that is a hardware issue with the sensor.

1 Like