Navigator board reboot when commanded to move

Hello all. First time underwater build, built custom drones and ai tanks. I am running into an issue I can’t figure out.

I can test each motor and they all spin, and they all spin in the correct direction. I have full network access and can see video. I can leave it armed or disarmed for any length of time and it will stay up.

The second I tell it to move I see one twitch of the props and then I hear the ESC music you hear when they first are powered up, and then QGC shows disconnected. I have to wait for the 2 or so minutes and then its rebooted and back up.

I tested the ubec its putting out 4.95v which is not 5.0. It puts this out regardless of load its putting out that with no load and it also puts that out when I command it to move and it then reboots. Is 0.05v causing this the system stays up at 4.95 as long as I am not trying to move so it must work off that power level, and it doesn’t go lower when I try and move.

I can change the ubec to 5.5v but then I think its to much voltage for the navigator.

I ordered the bluerobotics ubec today to see if that is the issue, but would still love to hear if anyone else has ever had issues like this?

Hello Fred,
my BR2 works with a power supply via cable, but I had the same problem at the beginning when the voltage was too low.

Try with the values of

in QGroundControl. This reduces the power requirement somewhat.

Thank you I will test this out tomorrow and write back.

Hi @nfored, welcome to the forum :slight_smile:

If your vehicle is rebooting when you apply thrust then it’s most likely a power supply capacity issue that means the onboard computer and/or autopilot are losing power, then turning back on once the power returns.

This comment covers a few approaches to resolving that, including using a higher capacity regulator (e.g. the 5V 6A one we sell, that you’ve said is on the way) and/or power supply, and some autopilot parameter options for mitigation (including limiting joystick gain, as @divebubble has recommended).

Note that, as specified in my link, limiting joystick gain does not apply to the vehicle’s own control systems, so won’t help if there are strong perturbations while the vehicle is in stabilise / depth hold modes. I’d recommend using the MOT_PWM_MIN/MAX parameters instead, as they should scale down the allowable output range (rather than scaling down the pilot’s input range).

Sorry to ask clarifying question but want to be on the same page. When the Blue Bec gets here and is installed, do I also need to make these changes, or are those changes just to compensate for the ubec not putting out 5v.

My slip ring is 2a so I don’t think without replacing that topside I could send current down needed for the nav/rpi.

Thank you to both @divebubble and @EliotBR

As an update for all this is the battery I am using it is two years old but I did just buy two new ones so I will also test those, but quick math says they can handle the 250 amps. I will post one more update once the new bec is here and post results of testing with old bec fresh lipo and new bec old lipo and new bec new lipo.

Thank you all for your help.

|Voltage / Cell Count|14.8 Volt (4 Cell)|
|Battery Capacity (mAh)|10000|

This is still an issue with the blue bec which outputs 5.14v i didn’t change the js but did change mot_ settings.

I just changed the js settings it still happening. Next step is to test with a new lipo, but I have a feeling this is something else I am missing someplace.

Tried brand new lipo again 250 amp lipo, same results. The one thing that changed that makes me think there are 2 issues is the pi no longer shows throttled logs, so the bec did fix that. I can give motor commands for literally 1 second I can move in direction if I pulse the motor, but try to move more than 1 second it reboots. This is always in manual control and with joystick and virtual joystick, updated to the daily build of ground control still no joy.

Could the navigator be bad? Should i wire a usb c connector to the bec and power the pi through that. If the pi stays up might show the issue is not so much power issure with the pi.

So to sum up.

Bought new blue bec.
Bought new battery.
Bec puts out 5.14 volts.
Mot_pwm set to 1700 and 1300 tried 1600 and 1400 no difference.
Js_ values set to whats above.
Pi shows no throttling after bec replacement.

So tonight I swapped out the raspberry pi and tomorrow I will charge my second new battery so that test will be two new never before used batteries, a new rpi, and the upgraded bec pretty much every part of the power and control system will have been replaced accept the navigator.

Support asked me to work my issue here so the community can also see the answer. For my part I will have done all I can think of, waiting for next steps.

Replaced Raspberry pi, same results. I noticed that the gstreamer was taking up sometimes two full cores I dropped my video down to 720p and 25fps, this dropped gstreamer cpu usage but I am still stuck.

Sent support some photo’s will update test steps they have me take or if I attempt to swap the navigator board then I will update that as well.

Might be to soon to tell but i suspect they pinpointed the problem right away. I used something i never used before a smoke stopper, having never used it i waa mistaken in its usage and is NOT designed to be left on. I was afraid of condensation causing a short so thought this was a good idea.

So while its to late to test tonight i suspect this post will be marked as solved. First response resolution possibly from Daniel.