Navigator board Ardusub Firmware error

Hi guys,

I know that it is just a few days after the new Navigator board arrived and I had a play with it last week.

I compiled and used Sub4.1 firmware (which I pulled from Github) with custom frame for ROV. Before I compiled, I used the configurations for Pixhawk1 boards.

However, when I tried to upload the firmware, there was an error popped up as shown, does that means the file is corrupted and cannot be used or is it using wrong board configuration option ? Thank you for your response !!

Hi @qnguyen, welcome to the forum :slight_smile:

While their input and output functionalities are similar, the Navigator and Pixhawk1 are different devices, and have different hardware that needs to be configured.

I asked internally what the process is for building ArduSub for Navigator and was told it should be the same but using ./waf configure --board navigator instead of ./waf configure --board pixhawk. You can use ArduSub-beta to checkout 4.1, although you seem to have figured that out (or something equivalent) already :slight_smile:

On the file type, instead of the .apj files that we generally use for the Pixhawk,

Hi Eliot,

Thank you for the tips, it works fine for us now. Turns out I have chosen the wrong board configuration !!

1 Like


I get this file and am able to put it in the navigator. But once it’s on the board I loose the com with my rov.

First I thought my version of ardusub was not good but then I tried with the codes unchanged and it was the same.

What do you do with this ardusub.elf file to make it compatible with the board ?