Home        Store        Learn        Blog

Mini Computer will not connect to ROV

I am trying to set up a Mini Computer to work with the BR ROV.
I have been through the the Network configuration several times, even Reset the Adapters and reconfigured them and tried again, but no luck.Ethernet 3 is the only adapter on the Network setup.I have included these Photos. for any ideas. I have been through the Trouble Shooting Tutorials.

This is the computer i am trying to connect to.

Mini PC with Windows 10 (12GB RAM/128GB M.2 SSD Storage) - Small Desktop Computer with Intel Celeron J4125, Micro Portable Server with Expandable SATA Storage Up to 2T, Support Bluetooth & Wi-Fi


Hi!
There are different solutions for connecting your computer.
Since your computer reports “Network cable unplugged” there is no communication via Ethernet adapter. Try connect something else to this port to verify the port is working.

If you are using BR ROV via USB and topside blue “FXTI interface”, this adapter should show up in your network list. Using this FXTI box there is two LEDS on top; are they lit?

1 Like

Thanks for the reply
I connected the Ethernet port via ethernet cable to My desktop computer and it shows that it is connected. So the ethernet port is working fine
I went to the Device manager and it showed all is working properly. The fixti box shows both green lights.
I connected my Laptop that i have been using with the ROV and the whole ROV system works fine.

I am trying to make a Compact system with mini computer to Stay on the Boat, instead of using a laptop, is what i am trying to do.



Hi @Rontom,

Your IP configuration looks fine. If everything is plugged in and the network is configured correctly, you should be able to access the Companion Web Interface (http://192.168.2.2:2770) :slight_smile:

You mentioned you’ve been through the network configuration and troubleshooting steps, but haven’t provided confirmation/details for most of them. My main suspicion is QGroundControl may not be allowed through your firewall, but there could also be other issues.

I’d recommend checking the QGC firewall options, and if that’s not helpful then please confirm each relevant troubleshooting step, and provide the output for any that don’t work as expected :slight_smile:

Virus and Firewall were turned off after i had the computer running, I downloaded QgC 4.1.4, but could not make it work , so i decided to uninstall it and Reinstall a older Version of QGC, that i down loaded off of BR Software page, still no connection.
Brought up the Log file on the Console of the QGC as seen in the photo, shows its not connected, I checked all the Hard wire connections between the ROV, several times, they were fine, could not make the companion web interface work, (http://192.168.2.2:2770), used the exception rule for allowing QGC through the firewall, did not work that way either, Turned all the Firewall sections totally off, still did not work.
Went through the Auto Connect settings on QGC.
Swapped connections on the USB ports on the Mini Computer,
Rebooted ROV, Rebooted Computer several times.


If you open Command Prompt, what is the result from running

ipconfig

From the troubleshooting steps,

The output should show that your Ethernet IP address is 192.168.2.1 and the subnet mask is 255.255.255.0.

Assuming that part is fine, if you run

ping 192.168.2.2

(press CTRL+C to stop early), do you get a response like

Reply from 192.168.2.2: bytes=32 time=8ms TTL=64

or do you get

Request timed out.

I’ve also raised this internally, in case someone has other ideas for relevant things/setting to check.

Following up on this, the software team suggested you’re likely configuring the wrong device/connection. The one in your photo specifies it’s a “Realtek PCIe GbE Family Controller”, so represents your computer’s ethernet network card, whereas the ethernet-USB converter from in the FXTI should appear as “Realtek USB FE Family Controller” (perhaps that’s the other “Unspecified” device, that’s not shown in your photo?).

I have it going now, You were right I was trying to use the wrong adapter
I pluged into several USB ports and watched The adpater setting window while i was doing it, I found the Right adapter and entered the IP adress for the ROV and it opened right up.

Thanks Eliot

2 Likes