Home        Store        Docs        Blog

Mac QGC no comms with BlueROV2


(Dale) #1

G’day all,
I’ve finished assembling my BlueROV2, and have powered up the ROV for the first time.

Running Mac 10.12.6, and have installed QQC 3.2.4 rev 4.

Following the instructions on the Mac software page, I have the Fathom Tether interface board powered up, and linked to both my Mac, and the BlueRov interface board.

QGC shows a red text “Waiting for Vehicle Communication” prompt. There are no comms with the vehicle.

Ive tried restarting the mac, starting the ROV, then the comms, and the other way around. The software setup manual is silent on startup order, so I’m unsure if that is critical.

There is no ArduSub text in the splash screen (per screen shots in the manual), and no vehicle related settings.

I have the network settings as per manual:

198.168.2.1
255.255.255.0


(Jacob) #2

The startup order does not matter. Please verify the network settings are set correctly (not 255.255.0.0. by mistake). Also check that the ‘UDP’ option is checked (enabled) under the ‘Autoconnect settings’ in the General tab when you click the purple ‘Q’ icon.

With everything connected and powered up, please open a terminal and type ‘ping 192.168.2.2’ as well as ‘ifconfig’, and paste the output of the commands here.


(Dale) #3
  1. Network settings copy pasted:
    198.168.2.1
    255.255.255.0

Network Status connected.
Ethernet is currently active and has the IP address 198.168.2.1.

  1. Q icon/General Tab/ Autoconnect settings/UDP option is ticked ( as are all other options)
    I have not changed any settings in QGC since installing

3

PING 192.168.2.2 (192.168.2.2): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5
Request timeout for icmp_seq 6
Request timeout for icmp_seq 7
Request timeout for icmp_seq 8
Request timeout for icmp_seq 9
Request timeout for icmp_seq 10

killed the process about here. Ping obviously not hitting.

ifconfig
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
options=1203<RXCSUM,TXCSUM,TXSTATUS,SW_TIMESTAMP>
inet 127.0.0.1 netmask 0xff000000
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
nd6 options=201<PERFORMNUD,DAD>
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=b<RXCSUM,TXCSUM,VLAN_HWTAGGING>
ether c4:2c:03:17:c7:f6
inet6 fe80::c07:52c7:b392:1ead%en0 prefixlen 64 secured scopeid 0x4
inet 198.168.2.1 netmask 0xffffff00 broadcast 198.168.2.255
nd6 options=201<PERFORMNUD,DAD>
media: autoselect (100baseTX <full-duplex,flow-control>)
status: active
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
ether d8:a2:5e:91:53:dd
inet6 fe80::8d5:26d7:eb30:20f1%en1 prefixlen 64 secured scopeid 0x5
inet 192.168.1.118 netmask 0xffffff00 broadcast 192.168.1.255
nd6 options=201<PERFORMNUD,DAD>
media: autoselect
status: active
fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
lladdr 60:33:4b:ff:fe:7c:61:f8
nd6 options=201<PERFORMNUD,DAD>
media: autoselect
status: inactive
p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
ether 0a:a2:5e:91:53:dd
media: autoselect
status: inactive
utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 2000
inet6 fe80::dfb5:5b3b:4e5f:b948%utun0 prefixlen 64 scopeid 0x8
nd6 options=201<PERFORMNUD,DAD>


(Dale) #4

Oh,
both fathom tether boards have link and power lights on steady green
Both ethernet ports flashing green and yellow


(Jacob) #5

Are you running a firewall or antivirus software?


(Dale) #6

No firewall (checked in Network Prefs, firewall is off)

No antivirus SW.


(Jacob) #7

Do you see lights flashing on the ethernet port of the Raspberry Pi? Have you connected the blue and white wires from the tether to the Fathom X inside of the ROV?


(Dale) #8

Mac Fathom controller shows flashing yellow/green,

Blue ROV Fathom controller shows flashing yellow/green

Raspberry Pi Flashing green only, yellow is solid.

Fathom X wires are connected white + and blue -ve on both Fathom X controllers.


(Dale) #9

Solved.

I was running a MacBook Pro to test. Switched to a MacMini to see if I had ethernet probs on the MacBook.

I do.

As soon as I plugged the ethernet cord from Mini to FathomX topside, completely different results. Powered up the ROV, and have full functions.


(Jacob) #10

Ok, a physical issue with the port would explain the problem. I was a bit perplexed as everything else appeared ok. If you can’t fix the port, you may be able to use the macbook with a usb-ethernet adapter.


(Dale) #11

Thanks.

there’s something going on with the ethernet port on the MacBook. It connects to a couple of modem/routers and a printer via ethernet, but not the BlueRov.

I’ll try McBook -> FathomX -> tether -> FathomX -> routers/printer and see what happens.

Dale


(Dale) #12

Oh, while you are about. The BlueRov2 kit I got had a 19mm x 400m heat shrink tube. The build manual doesn’t describe it.

Do you know its intended purpose?


(Jacob) #13

This is part of our spares kit, it may have accidentally found its way into your box. The heat shrink in the spares kit is for cable repair. It fits over the penetrators and is adhesive lined.


(Dale) #14

OK, makes sense.
I received two vacuum pumps, not one. I paid for one!
Might send it back, or swap for a T Shirt.

Dale