Home        Store        Learn        Blog

Low-Light HD USB Camera lower frame rate (17fps vs 30fps)

The Low-Light HD USB Camera on the BlueROV2 has lower frame rate (17 fps) than the one in the setting (30 fps). This frame rate has been measured using ROS gstreamer wrapper. I checked the bandwidth between the Raspberry Pi and the laptop connected with the fathom, and it was a little bit less than 80 Mbps.

After several tests to isolate the problem (including trying a spare Low-Light HD USB camera, a different Raspberry Pi), the problem seems to be hardware related, and in particular electrical noise affecting the cable: when the camera is actually closer to the camera mount (the disk) the framerate drops, while when it is farther, it gets back to 30fps. It seems also that wrapping with some shield, or twisting the cable, affects the framerate.

Here a video showing this effect: at the beginning I start farther, showing the framerate on the laptop screen to be around 30fps, while when I leave it closer to the camera mount, it drops to around 17fps.

Any insight on how this could be fixed?


Hello Alberto,

We noticed this issue before, you can track it here: https://github.com/bluerobotics/companion/issues/233
I ran some quick tests on this issue while I worked on fixing some camera controls, but unfortunately we still don’t have a solution.

Thank you William, I am posting then on the issue on github – I have an update, so please whoever gets to this post, go to the github issue.

1 Like