Home        Store        Docs        Blog

Lights setup - calibrate ON


(Grand_Ours) #1

Hello,
When i control the light with GamePAD,
"
Light 1 level (%) = 0 --> light OFF
Light 1 level (%) = 10 --> light OFF
Light 1 level (%) = 20 --> light ON
"
how to calibrate so that light 1 lights up at 10?

Thanks
PS: with the last software updates - September 14 2017


(Jacob) #2

Hi Xavier, The software running in the lights has a low pass filter on the input, so it take a couple of seconds for the lights to come on. Have you tried pushing the button once, then waiting?

Can you open the Tools->Mavlink Inspector and expand the SERVO_OUTPUT field, let me know what it says under channel 7 when the lights are at 0, 10, 20%.


(Oliver Blum) #3

Same here, BlueRov2 built from this week. 4 Lumens attached. Lights only start comming on at 20%, no matter how long the wait is.


(Svein H.) #4

Had the same issue but solved it by decreasing it to 6 steps. First step will then be 17% and the light will respond on all 6 steps.


(Jacob) #5

As of ArduSub 3.5.2, you can configure the minimum output signal for the lights channel.

To raise the minimum output signal, increase the value of the SERVO7_MIN parameter. The range between _MIN and _MAX will be divided by the number of steps selected, so you may use however many steps you want and still get the desired behavior.

Thanks for bringing this to our attention @xav83130!

-Jacob