Home        Store        Learn        Blog

Lights in QGC shows 100 % while lights are of

My lights start with 100% when the lights are of. When i increase the steps, the % decrease. it seems to operate oposite way then before. I did a software update and the happend after that. How do i reverse this?

Hi Svein!
Mysterious, I upgraded to QGC 4.1.2, Ardusub 4.0.3 and Companion 0.26 without problems.

If you want to try to inverse lighting output, there is a setting in parameters to reverse.
In QGC/settings/vehicle/parameters you enter your lighting channel in the search field.
In my case RC9
There you can change the channel to “reversed” to see if that helps you
If you just want to reverse the joystick function, you can switch mapping the lights “up” and “down” buttons

1 Like

Thanks for that, i will try and see.

I just updated to the same QGC version as yours. My upgrade was to 4.0.5. There was a lot of changes here, how do i remove the “No GPS Lock for video” alarm window?

It might disappear when connection to positioning system works
If not using positioning system, there seems to haven been a bug:

Ok, how far back do i have to go to sort out this problem, 4.0.5?

I hope the bug will be fixed.
If you want to try different older QGC versions: Releases · mavlink/qgroundcontrol · GitHub

I went back to 4.0.5, but the lights still show 100% while they are of. can it be something in the ardusub that cause this?

You are right, the problem should be in the Ardusub/pixhawk settings

First, make a backup of your current parameter settings (QGC/settings/vehicle/parameters/tools)
Check the parameters in QGC/settings/vehicle/ summary tap
Under “frame” check that its right, under “Lights” check the channel no
If you have your old parameters already backed up, try to reload them from QGC

Then you could try to “refresh” or “restore” Ardusub at (QGC/settings/vehicle/parameters/tools)
Antoher way to do that is by 192.168.2.2:2770 system page, here you also could try to restore firmware and parameters

If you havent version 4.0.3 already, you could update to “stable” here.

Hi Bo,
Just an little update.
I got some good tips from BR tech US. that solved the issue.
It all started with changing AUX output due to a setup after a software crash. The AUX port 2 on pixhawk that until now had been used for the camera servo was recomended used for the light so i swopped 1 and 2. Since the default settings is reverse mode for this output it showed the scale in the oposite way when it was used for lights. I have wired the AUX.port back to BR. recomended settings and downloaded default settings and everything is running as normal again.

1 Like