Home        Store        Learn        Blog

Joystick support requires MAVlink MANUAL CONTROL support

Hi all,

I am trying to use the joystick, but when I connect Pixhawk to QGROOUNDControl I get the following message:

Joystick support requires MAVlink MANUAL_CONTROL support. The firmware you are running does not normally support this. It will only work if you have modified the firmware to add MANUAL_CONTROL support.

So how to add MANUAL_CONTROL?

I downloaded the code from here: git clone https://github.com/bluerobotics/ardusub.git
and follow this instrunctions: http://ardusub.com/developers/

But nowhere it says how to add MANUAL_CONTROL, what do I need to modify? What files I need to change?

Any help is greatly appreciated.


Manual control support is built into ArduSub already! You’re good to go.


The box that shows up in QGC is just a warning to users that their vehicle must support the MANUAL_CONTROL message. ArduSub does support it but none of the other ArduPilot code does.

You can just click okay and continue!


Hi Guys,

How I can setup the joystick? I istall the firmware on the PX4, but not find were I setup the joystick on the QGround.



Hi Jonathan,

If your joystick is detected, then a “Joystick” tab should show up on the settings page in QGC once the vehicle is connected. Do you see that? What joystick are you using and what operating system?




Thanks! I will check my joystick setup on the computer first! I use Windows and I will use a RC control, with simulator cable (like attached).



Okay. The joystick has to be recognized as a standard joystick to the operating system. I’m not sure what the flight simulator joystick normally use. It may work fine.

Also note that the joystick buttons for ArduSub and configured for standard push-buttons on a gamepad controller. I don’t think they will work with the switches on the transmitter.


Dear Rusty:

Good day

I use PX4-Vectored F/W and logitech 710 joystick, But I find Motor is no any respond when I move rocker of joystick( has already Calibrated) and the PWM output always 1.5ms.

Info: PX4-Vectored download form “http://ardusub.com/initial-setup/firmware.ardusub.com”, I also try “PX4-bluerov and simplerov,vectored6dof” also no respond.

Could you teach me what’s the problem?

Thanks you very much and wait for your reply ^^.


I would check that the parameters are correct, especially that BRD_SAFETYENABLE should be set to “disabled”. This disabled the Pixhawk’s external safety switch, which is not normally used on an ROV.

Please see here for a complete list of parameters that should be set: http://ardusub.com/initial-setup/#configuring-parameters



Dear All,

After many time of work, I can connect the qgroudcontrol on my android tablet, over wifi. I Use a wifi router, to make a bridge from the ethernet cable and the tablet. I have all work on de android, include video. The problem now is the joystick that no work on the qgroundcontrol on android. I check the joystick in others app’s, and work well. Somebody know how to work the joystick on the QGC on android?



We currently do not support using android/ios to control the Sub. Joystick functionality on those platforms is still a work in progress.