Jetson Nano as Onboard Computer

Hello,
I am working on developing a custom Mini ROV and would like to use the Nvidia Jetson Nano as my companion computer and the BlueRobotics Navigator as my autopilot board. I have been unsuccessful in installing the BlueOS-Docker on the Jetson Nano. Can I kindly have some assistance?

Hi,

We don’t have a Jetson to test with, but we can help troubleshooting. What errors have you ran into?

Thanks William. I would appreciate your help.
This is the error that shows up in the terminal when we run the BlueOS-Docker installation script from github.

the issue seems to be on this line. What is the default username for the distro you are using? try using that instead.

Thanks William. I was able to fork and modify the script, however when i rerun it, i run into another error.

I think our images are armv7, which should work under a v8 host just fine…

can you try this patch?

Hello William, I was able to add your patch and run the installation script. However, BlueOS does not seem to run over the network. Any ideas why?
Here is a shot of the final messages from the terminal after the installation completed.

Hi @BennyAmk,

The following message about the hardware not being identified, is not a hard error, only a message to help us identify if there is the hardware support for the NVIDIA Jetson Nano Developer Kit in our installation script.

Everything else should proceed as expected.

Which system are you running on your desktop computer ?
If you are running though linux, make sure that avahi is running and you can access BlueOS though the mdns address.
Try to access the board via the IP address directly on your browser, if that does not work, connect via SSH and run docker container ls and return the output here.

Hi @BennyAmk, welcome to the forum :slight_smile:

As an additional note on this, our Navigator is not an independent flight controller - it requires a Raspberry Pi 4 as a host computer. You could conceivably have both a Raspberry Pi 4 + Navigator and a Jetson Nano in your vehicle, but if you’re wanting a single onboard computer then you’ll either need to use a Raspberry Pi 4 instead of the Jetson Nano, or use a different flight controller board instead of the Navigator.

What do you mean by “BlueOS does not seem to run over the network”? How is your computer connected to the Jetson Nano (e.g. ethernet / local wifi network / …?), and how are you trying to interact with it (e.g. SSH, browser, etc)?

Hi @BennyAmk,

We just started deploying arm-v8 docker images, you may what to recall the install script to install the new version.

Hi @EliotBR ,
I would also be interested in the Jetson Nano/Navigator combination. It seems the navigator fits on the 40 pins of the Jetson Nano as it does on the Pi4. Could you explain why a Pi4 is needed ? Is it because of ArduPilot firmware compilation issues ? Or is it because BlueRobotics doesn’t want to support this ?
Thanks

The Navigator was designed quite specifically around the hardware of the Raspberry Pi 4, to the extent that it’s not even supported on the Raspberry Pi 3. While in theory it could be electrically connected to another board with the appropriate hardware capabilities that’s not a use-case it’s been developed for or tested with, and trying to do so would likely require adjustments to the Navigator support code in both BlueOS and ArduPilot’s HAL (hardware abstraction layer), as well as a new heat sink (since the one it comes with is custom designed to interface to the Raspberry Pi 4’s ICs).

In previous internal discussions I’ve been told that

which is presumably related to how configuration is currently done.

There are many things we want to do, but don’t have sufficient resources to focus on.

I’m sure Blue Robotics would be happy if our Navigator flight controller could be used with more onboard computer options, because that’s a valuable feature to have. That said, it’s not an existing feature, and given our other priorities it’s not something we can currently allocate development resources to attempting by ourselves, and may not be practical to do even if it turns out to be technically possible. For what it’s worth, if it was already implemented and being used then I imagine we would try to provide support to maintain the functionality.

Hello ,
My team and I trying to use jetson nano as the companion computer .
Normally there will be some rework we shall consider while migrating the companion software setup.
are there any guidlines/steps on what to do in that case ?

Hi @bea, welcome to the forum :slight_smile:
I’ve moved your post here, because it’s on the same topic as this thread.

As a summary of the current state of things, we don’t currently have clear guidelines or steps on using a Jetson Nano as the onboard computer, but BlueOS’s design means it should be possible to install, although there may be some slight modifications required to the installation scripts for it to work completely.

My understanding is that we plan to officially support Jetson Nano (and other boards) at some point in future, but haven’t had the time or development resources available yet to properly try it out, so in the meantime the only attempts have been by members of the community. If you actually try to do it and run into issues then we’d be happy to help you work through them if we can :slight_smile:

As a minor side-note, if you’re talking about our old Companion Software (not BlueOS) then that was specifically designed for the Raspberry Pi 3B, and is not supported or intended to be used on any other platform or architecture. It’s also no longer being developed or maintained, so we wouldn’t recommend using it or porting it to another platform.

Hello! Looking forward to upgrade the 1st version of BlueROV2 with a stronger setup and fell into this thread. Finally, has anyone made it to run bluerov with jetson nano and navigator? Moreover has anyone checked out the voxel 2 from modalai ? Could this work?

1 Like

Hi. I’ve used BlueOS on Rasp4b but didn’t have tried on a jetson nano. But me and my team have a limited time. So does BlueOS works on Jetson Nano specifically on Jetson Nano Orin?

Hi @erkamtb,

I’ve moved your post here because it’s on the same topic.

This is the most recent thread I’m aware of around Jetson Nano functionality, and it seems they were able to install it but it was somewhat tricky to get it working at the time.

I’m aware that our software team have been putting some extra work into BlueOS compatibility recently, but that’s still ongoing.

To specifically answer your question, it might be possible to get working, but it’s not something we’ve done our own testing of, so I couldn’t call it officially supported at this stage. If you try it out and want some help we can try to provide some advice, but if you’re short on time it’s likely safer to go with a known-working board.

Welcome to the forum @akaraolanis :slight_smile:

I don’t believe anyone has mentioned it, but you’re welcome to make a new post about it if you have specific questions and/or want a place to discuss it.