Issues upgrading companion from 0.0.15

I just received a blueROV2 for my research and I was attempting to update the firmware. The companion had 0.0.15 version and I was able to update it via the webpage interface, then I updated the pixhawk in the same manner. I rebooted the vehicle and it reverted the updates back to the original state, I tried this again and after rebooting the system won’t allow me to connect anymore. I am met with a destination host unreachable after ping Any thoughts on what went wrong here? I am thinking I should just flash the firmware manually, but would appreciate some guidance

Hi @cmarq,

I’m not sure what’s going wrong here, but I believe there have been some external changes since Companion 0.0.15 was released that may have caused its updating system to stop functioning properly.

If you’re wanting to stick with our old Companion software (which is no longer being developed) you can follow the Companion flashing instructions. Otherwise you may wish to try out BlueOS :slight_smile:

Hey Eliot,

I was able to remove the SD card from the Raspberry Pi and flash it work the latest firmware and everything works now

1 Like