Home        Store        Learn        Blog

How to recovery Ping Sonar

Hi all,

I went to the recovery guide https://docs.bluerobotics.com/ping-viewer/firmware-update/#device-recovery to try and solve the issue I’m having with one of my Ping Sonars and the webpage wasn’t useful; it’s under improvement. I also referenced Ping1D not detected by Ping Viewer Ping Viewer doesn’t the detect the Ping1D automatically. When trying to connect manually Ping Viewer doesn’t show that device is available. I know the BLUART USB to Serial and RS485 Adapter and the Micro-USB to USB-A Cable I’m using works because I utilized them to connect another Ping Sonar I have to Ping Viewer.

I tried swapping the TX and RX wires and that didn’t work. I opened the device to see if LED is blinking and the green LED wasn’t blinking. I believe that I have to reset the firmware. I know that I hold the “BOOT” button down (I don’t know how long) and use Ping Viewer to upload new firmware. What am I missing?

Hi Cameron,

Not sure where you got that link but it seems to have an extra slash (before the hash #). It should be like this instead :slight_smile:
I searched the forum for the incorrect link and found a couple of examples of it, which I’ve now corrected in those posts. Let me know if you got it from somewhere else.

Out of interest, does the Ping1D get detected by the companion computer? You should have something like FT231X_USB_UART in the “Detected Devices”, and pingproxy and pingmav should be present in your “Active Services” on the System page of the companion web interface (http://192.168.2.2:2770/system). Note that pingproxy and pingmav only start if the ping is detected on startup, so you’ll need to plug it in before turning on the ROV (or reboot the RPi via the companion interface if it was already powered on).

Tangentially, in case you haven’t already seen it, we recently released a new version of Ping-Viewer. It’s got some nice visual/usage improvements, but also fixes a bug with flashing the Ping1D, so is useful for updating the firmware. That does still require the ping to be detectable though, so is more useful once your current issue is fixed :slight_smile:

1 Like

Thank you Eliot! That helped a lot.

1 Like

If that comment/explanation solved your problem could you mark it as the solution?

If it’s not yet solved then feel free to post any relevant follow-up questions :slight_smile:

When I was connecting with the Ping1D I wasn’t connecting it to with the BlueROV2 Pixhawk and its companion computer, but with an Arduino Mega. Your explanation was part of the solution I needed. However, I used the “Device Recovery” process and the final output I got from the flash procedure after multiple attempts was:

stm32flash 0.5

http://stm32flash.sourceforge.net/

Using Parser : Intel HEX
Interface serial_posix: 115200 8E1
Failed to init device

It’s clear now that there’s likely something wrong with the hardware. I’m going to have to buy a replacement.

Fair enough. It would be great if you could report this to support@bluerobotics.com (link them to this thread). That’s useful for our internal issue tracking, and if the issue was from our equipment not performing/working as expected then you may be able to get a replacement or refund :slight_smile: