Home        Store        Docs        Blog

Ping1D not detected by Ping Viewer

Hi there, I am having an issue trying to connect Ping1D to my computer using Ping Viewer.

Ping Viewer does not detect Ping1D automatically. When connecting manually Ping Viewer shows that device is available and connected, but nothing happens really (no pings are emitted; when trying to set speed of sound software just resets it to 0).

I am using revision 1 of this usb to RS485 UART serial converter:

When connecting manually to the USB port through Ping Viewer, indicator lights on the converter start blinking, which must mean that data is being transmitted, but no activity on the monitor can be seen.

I also tried switching Tx and Rx wires. Behaviour is same on both OS X and Windows machines.

What could be the reason?

Hi Natali,

Check if there is a proper 5V and ground connection between computer and sensor.
If you are still having this problem, please follow our recovery guideline: https://docs.bluerobotics.com/ping-viewer/firmware-update/#device-recovery

Thank you @patrickelectric for your reply.

So I followed recovery guideline.

  1. I opened up the device to see if LED is blinking, as the guideline says. The green LED was blinking but Ping Viewer still did not detect the device, so i decided to proceed with recovery.

  2. When I ran ./stm32flash executable, an “exec format error” occurred, so I decided to install stm32flash program on my computer and try to flash firmware on the device with that.

  3. When I executed this command “stm32flash -v -g 0x0 -b 115200 -w .\Ping_V3.26_115kb.hex /dev/tty.myserialport” I got “Failed to init device” error.

  4. Then I decided to try and flash new firmware manually through Ping Viewer. So once again I connected manually Ping1D to the Ping Viewer, chose downloaded .hex file and tried to make Firmware Update. First time an “unknown error” occurred. Second time there was another error “Link is not open to do the flash procedure”.

So, 5V and GND connections are fine, I tried switching Tx and Rx wires, I tried to use another FTDI RS485 UART serial converter in case the first one was the problem, manual firmware update has failed for unknown reason. It seems like the board itself is not being recognised at all.

What else can I do?

Hi Natali,

If the LED is blinking you should be fine, have you tried different serial-usb adapters ?
The recovery guideline is to recover problems related to firmware side, if the led is blinking, the firmware is running and fine, no recovery is necessary.

Thank you for your help Patrick.

Can you give any advice, how to pick the right adapter & what could be the problem with the one I picked (link to adapter’s documentation in first post)?

I will try different adapter as soon as I get the chance and will let you know how it worked out.

Hi,

I would recommend to buy our serial adapter:

Any USB-Serial adapter (USB/TTL RS232) will work.

Ping1D is TTL Serial and not RS485, bluerobotics adapters provides both TTL Serial and RS485 with different connectors.

So this one should work?

The reason I did not buy BLUART in the first place, was because shipping takes time, the one I chose was available in my home-country :slight_smile:

Hi Natali,

It appears to be compatible, any option here will work:
https://www.ftdichip.com/Products/Cables/USBTTLSerial.htm

1 Like

Hello,
you should try different usb cables. I had the same problem with my ping and believe it or not-- the 5th usb cable i tried worked perfectly. Hope this helps,
William