Home        Store        Docs        Blog

How to adjust compression on new HD cam?


(Michael Gobin) #1

Hi,

I’ve installed the new HD low-light camera on my BR2 and I have a lot of pixelisation. Bitrate is too high. I had this problem with the previous Raspberry Cam that was fixed by changing the bitrate from 25mbps to 15mbps. I have no idea how to adjust compression settings on the new HD USB cam. Could you help please ?

In addition, any idea on how to test the connectivity and the bandwidth of the connection between BR2 and to surface laptop ? I have done a few modifications to the cabling with a SUBCONN connector on the BR2, and I’d like to measure how it impacts the bandwidth… a simple “ping” in not enough for this.

Thanks and regards,

Michael.


(Rusty) #2

Hi Michael,

What operating system are you running? We recently had this same problem on a laptop running Windows 7 and it was completely resolved by switching to Windows 10 on the same computer.

There’s actually a bandwidth test built into our Companion interface, but it’s still in beta. You can find that at http://192.168.2.2:2770/network.

-Rusty


(Michael Gobin) #3

Hi Rusty,

Thanks for your feedback. I think we are running W7 indeed. The system has been dispatched offshore today for testing in real conditions so the guys will live with this for the coming days. I will investigate if I can upgrade to W10 and fix the issue when they are back.

Concerning compression, any possibility to tune bitrate and maybe resolution if I prefer to stream 720p instead of 1080p ?

Thanks for the bandwidth testing tool. I’ll test it when the system is back.

Cheers,

Michael.


(Rusty) #4

Hi Michael,

Okay, I think upgrading will fix the problem. We don’t officially support Windows 7, just Windows 10.

I don’t think we have any experience tuning camera parameters yet with this camera but @jwalser would be the one to ask about that.

-Rusty


(Michael Gobin) #5

Sounds good, thanks ! I’ll let you know how it works. Michael.


(Jacob) #6

It is possible to adjust resolution, framerate, and color settings. I still have to add support in companion to make it easy to do this.

Right now, I’ve been using v4l2-ctl to test.


Color correcting the camera feed
Low-Light HD USB Camera
(Michael Gobin) #7

Great, thanks @jwalser ! Looking forward to having this integrated in Companion :slight_smile:


(Jacob) #8

Track progress here: https://github.com/bluerobotics/companion/issues/61


(Michael Gobin) #9

Good news, I managed to have the problem fixed upgrading to W10 ! Well, had to buy a new laptop too :slight_smile: ! But it works … however I’ll be happy to tweak the camera compression at some point … looking forward to having a solution.

By the way, I have also tested my connection speed using your tool, I got around 70Mbps in both download / upload. Not so bad for a 100MBps theoretical … with a Subconn and several connectors along the line !


(Svein H.) #10

I have just tested my New BR2 and have the same problem. i have tested it on two different Laptops with win. 10, but the problem is the same.
Can it be related to low Power tru the mini-USB to the Fathom card on the topside?
Will also mention that i have installed a small slipring in my drum, but i have devided 6 single wires in two pair to have enough mm2 tru the small sliprings.

I have also problem With the “Depth hold” function. it goes into peak Down or up as soon as i put it into


(Svein H.) #11

I added a extra powersupply directly to the USB-cable to the fathom card and it seems to have solved the problem With the Picture. now it is just the "Depth hold"problem left…


(Jacob) #12

@SHS, you need to reverse the directions of both the vertical thruster. Please switch the direction of motors 5 and 6 with the MOT direction parameters.


(Svein H.) #13

Thanks, that solved the problem :blush: