Home        Store        Docs        Blog

Help | No Video from my own compiled QGC code

ardusub

(ocenaman) #1

hi,
I git the code from https://github.com/mavlink/qgroundcontrol and compile it with Qt 5.7.1
But the UDP video stream is Unknow (version is 2017-05-31)
It can show the laptop camera video If I don’t connect the pixhawk.
I cann’t find out the error point with a lot of tries.
Thanks!


(Jacob) #2

Look at the bottom of the General tab on the Application Settings page. You will be able to select video source, choose UDP and port 5600. QGC is available pre-compiled, is there a particular reason you want to compile it?


(wdodo) #3

hi jacob
oh,I also have this question about it。If I download the latest code from github,there also has the question。

you can find that there is no available option below video source,include PORT.So what about my question.I have met the the same question from version 2017-5-3.I have downloaded the EXE of 5.25.this version is great.but I also want to compile it on my own for trying to get some optimization. thanks very much.


(ocenaman) #4

hi,jacob
Thank you for your reply.
I want to learn it deeply and hope to make contribution to the QGC on github.
BlueROV is a goodwork and I wish to join it if possible.

It seem to be failed that I cannot find the choose page which shows the UDP and port 5600.


(ocenaman) #5

Hi,It seems to be similar problem.


(Jacob) #6

Click the Purple Icon with a ‘Q’ on it.
You can see an example here.

Interesting, I have never seen the Unknown: UDP Video Source like that before, that’s where the option should be.

Trying now…

-Jacob


(Jacob) #7

Awesome! Let me know if you need help. You can chat on gitter too.


(Jacob) #8

Can you show me the other options in the menu that contains ‘Unknown UDP Video Stream’? I don’t see this when I’m running the same version.


(wdodo) #9

sorry to disturb you


(Jacob) #10

Aha! I think the problem is that you have not installed the gstreamer packages that QGC needs to link to in order for video to work. See here: https://github.com/mavlink/qgroundcontrol/tree/master/src/VideoStreaming#qgroundcontrol

-Jacob


(wdodo) #11

sir
is it necessary to re-compile after installing gstreamer?


(Jacob) #12

Yes. It takes a while, I know it’s too bad.
-Jacob


(wdodo) #13

ok,I test ok,thanks very much


(wdodo) #14

The problem seems to be solved ,you can have a try