Home        Store        Docs        Blog

Help in Rov and VM comunication


(chapulino1000 .) #1

acces attemp bluerov

VM to bluerov

viki@c3po:~$ ssh ubuntu@bluerov
ssh: Could not resolve hostname bluerov: Name or service not known

valid access
viki@c3po:~$ ssh ubuntu@10.0.0.20
ubuntu@10.0.0.20’s password:
Welcome to Ubuntu 14.04.3 LTS (GNU/Linux 3.18.0-20-rpi2 armv7l)

Ping example bluerov to VM
ubuntu@bluerov:~$ ping 10.0.0.10
PING 10.0.0.10 (10.0.0.10) 56(84) bytes of data.
64 bytes from 10.0.0.10: icmp_seq=1 ttl=64 time=0.709 ms
64 bytes from 10.0.0.10: icmp_seq=2 ttl=64 time=0.517 ms

Ping example VM to bluerov
viki@c3po:~ ping 10.0.0.20 PING 10.0.0.20 (10.0.0.20) 56(84) bytes of data. 64 bytes from 10.0.0.20: icmp_seq=1 ttl=64 time=0.607 ms 64 bytes from 10.0.0.20: icmp_seq=2 ttl=64 time=1.94 ms <strong>ifconfig in VM</strong> viki@c3po:~ ifconfig
eth0 Link encap:Ethernet HWaddr 08:00:27:b4:6c:dd
inet addr:10.0.0.10 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::a00:27ff:feb4:6cdd/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3487 errors:0 dropped:0 overruns:0 frame:0
TX packets:1447 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:460077 (460.0 KB) TX bytes:148828 (148.8 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:4538 errors:0 dropped:0 overruns:0 frame:0
TX packets:4538 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:625231 (625.2 KB) TX bytes:625231 (625.2 KB)
if config in bluerov
ubuntu@bluerov:~$ ifconfig
eth0 Link encap:Ethernet HWaddr b8:27:eb:10:ce:6d
inet addr:10.0.0.20 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::ba27:ebff:fe10:ce6d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:769 errors:0 dropped:0 overruns:0 frame:0
TX packets:241 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:95742 (95.7 KB) TX bytes:34871 (34.8 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:40 errors:0 dropped:0 overruns:0 frame:0
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3024 (3.0 KB) TX bytes:3024 (3.0 KB)

interfaces file

ubuntu@bluerov:~$ cat /etc/network/interfaces

interfaces(5) file used by ifup(8) and ifdown(8)

Include files from /etc/network/interfaces.d:

source-directory /etc/network/interfaces.d

The loopback network interface

auto lo
iface lo inet loopback

The primary network interface

#allow-hotplug eth0
#iface eth0 inet dhcp

ROV direct connection

auto eth0
iface eth0 inet static
address 10.0.0.20
netmask 255.255.255.0

hosts file

ubuntu@bluerov:/etc/network$ cat /etc/hosts

127.0.0.1 localhost
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

127.0.1.1 ubuntu
10.0.0.20 bluerov

hostname file
ubuntu@bluerov:cat /etc/hostname

bluerov

 

I think I should include in Bluerov or VM some form of link both in the execution of Roscore
Something about
export ROS_MASTER_URI=_______________

but not which of the two and would have to put , I would also like it to work : ssh ubuntu"bluerov instead ssh ubuntu@10.0.0.20 because I think there must come the problem of communication between VM and bluerov.

Thank you very much to all the world


(chapulino1000 .) #2

news

i use

export ROS_MASTER_URI=http://bluerov.local:11311

previusly to launch

in the rov

roslauch bluerov ros_core.launch

and also in VM

and lauch

roscore bluerov teleop_xbox.launch

roscore bluerov rqt.launch

 

in this moment the rov console say

Couldn´t find an AF_INET address for [c3po]

Any idea ?


(chapulino1000 .) #3

Solved

Simply adding in the .bashrc file of the VM

export ROS_IP=10.0.0.10

export ROS_MASTER_URI=http://10.0.0.20:11311

and in the .bashrc file of the bluerov

export ROS_IP=10.0.0.20

export ROS_MASTER_URI=http://10.0.0.20:11311

The comunication is ok.

Now the last problem is the node

HAZARD_ENABLE

can someone tell me how it should be disabled

add a picture