Home        Store        Docs        Blog

Gyro alert


(ooyama) #1

Today I went to a place took me a hour boat trip. When I got there, connect the battery, the pixhawk beeps another beep sound, then keep beeping on and on seems like it needs calibrating. The place QGC used to displays baro displayed garo alert, but the calibrate part is green light. Couldn’t get armed.

But after I returned, carried the rov to the place I stay, It’s all good again.

What’s the problem with that?


(Jacob) #2

Did you recalibrate the sensors after you updated firmware? How rough was the water when you plugged in the battery?

When the BlueROV starts up, it calibrates the gyroscope (rotation rate) offsets. It can handle gentle movements, but if the boat or BlueROV is moving a lot during this process the discrepancies between sensor values cannot be reconciled. You will get the gyro warning in this case, but you should still be able to arm if your ARMING_CHECK parameter is set to disabled (uncheck all of the options).

Do you have any options selected for ARMING_CHECK?

You can prevent the gyro calibration process at boot by setting the INS_GYR_CAL parameter to ‘Never’. Then you will not get the gyro warning, but it will make the navigation filter significantly longer to get the sensor values to converge and give you a very accurate attitude reading. It should still give you a usable attitude estimate pretty quickly for most cases. If you do this, I think you should do it while you are on land, so that the offsets are are calibrated once, and saved to something close to correct before you prevent them from being calibrated again.


(ooyama) #3

Thank you very much! I’ll try!