Grey screen while video stream

when I save the images from my bluerov2, a gray screen appears every 5 to 10 seconds (it lasts 1 second or 2). On the other hand, when I watch the recorded video, there is no trace of this lack of data. It bothers me to fly diving of course. Someone would have any idea ?

Sorry for my English, I’m French.

My guess is this:

it is very possible, but the last downloadable version of QGC on the Bluerobotic site is 4.0.5 … where can I find version 4.1.2 for BlueRov2?

Other releases to test:

I tried with version 4.1.2 and above, the problem is solved for the gray screen in video stream but I no longer have the joystick test on the general tab even after calibration.

4.1.x should solve the video issues, as @Boko mentioned. If you’re using 4.1 we strongly recommend >= 4.1.4, as that release contains several ArduSub related improvements that weren’t in earlier versions of QGC 4.1.

This seems odd, but I’ll respond to it in your other topic that you made for that issue.

Hi everyone,

in the last deployment of the BlueRov2 I did forget to start recording. During this dive I had no gray screen. When I start the recording, I have gray screen. After the software update, the count of appearance decreased. But when they appear occur, it’s really annoying. The appearance is randomized. I cannot observe any patterns.

The software is installed on a Windows 10 laptop. There is installed only essential software and QGC only, no games, no mail, no Office etc. During the deployment of the ROV, Bluetooth and WLAN are switched off.

Does anyone knows a solution?

Best regards

Hi @dr_stony, welcome to the forum :slight_smile:

Which QGroundControl version are you using? If you’re not already using 4.1, please try the latest recommended version, 4.1.6

I have 4.2.0 …

Apologies for the delay in responding.

4.2.0 isn’t a version we support for use with ArduSub - our latest recommended version is 4.1.6.

Previous grey screen issues have been handled by changing the video decoding options, as discussed here. These troubleshooting steps may also be helpful :slight_smile: