Depth sensor error, depth randomly resets to 0 during dive

Hey User community,
We’ve been trying to find a solution for a depth sensor error that we’ve been getting while our BlueROV2 Heavy is operating during Position Hold mode. QGC just says “Critical: depth sensor error” and pushes the ROV back to manual mode. The real kicker is that the depth sensor almost re-calibrates itself and resets the depth to 0 even if it is at depth.

We do have the WL DVL A50 installed with updated firmware. Does the DVL have a pressure sensor? Are the DVL and the Bar30 signals interfering with one another somehow? We haven’t noticed this error in manual mode and have briefly tried depth hold mode, but haven’t observed it there either.

Things I’ve tried:

  1. Double checked wiring and connections of the Bar30
  2. I’ve read in the WL DVL A50 setup guide there is a known bug related to pressure sensing. I changed the BARO_PROBE_EXT to 768 and saw the same result
  3. Saw on this forum post that the BARO_PROBE_EXT for the Bar30 should be 512 so I changed it to that instead.

System setup:
Navigator + Bar30 plugged into I2C 6 port
DWE ExploreHD camera
BlueOS 1.1.1 (Stable)
ArduSub v 4.1.1 (Stable)
QGC v4.2.8
DWE QGC v4.2.0-15

Running out of ideas. Thanks for any advice,

In case anyone else runs into this issue. Through some back and forth with BR support, the issue was some electrical interference on the I2C cable running close to the ESC boards. We found that the issue happened most frequently when changing directions quickly or at any gain over 50%.

Solution: Add a ferrite core or two to the I2C cable. This did require cutting, installing the bead and reconnecting. Below are instructions from @tony-white

Glad that did the trick @Bolli !
The instructions I shared are from the OTPS Power supply manual, but this can occur even if not using the OTPS. It should be possible to pass the I2C connector through the ferrite core, but you mentioned you needed to cut and re-splice to get it installed?

That’s right, the connector for the Navigator board - I2C was too large for me to pass it through the core. None the less twice like we discussed. The cabling was also too short with the double wrap, so I ended up adding a bit of length to each of the 4 wires while it was cut.

1 Like