Home        Store        Learn        Blog

Data Transfert issues, low rate

Hi All,

Here is my BR2 configuration:

Heavy configuration with 8 thrusters
Fathom x board in ROV and Top Side
300m tether, 4 TP

With this config, I can only have around 20Mbits data transfert rate in the WebUI.

I have made a lot of test, trying to determine from where is it coming from.

1- normal config : 300M tether, Fathom X board,
20MBits, same for 3 other pairs

2- without the tether, I ran a TP (2m long) between the 2 boards
35Mbits

3- Same as 2, but camera disconnected
40 Mbits

I also replaced the Boards (I have some spare), nothing changes.

I tried to power the boards with 5v charger (not from computers) in top side and ROV side, still the same.

All the TP are around 80 ohms (2 way), so 40 ohm for 1 wire.

I am now running out of idea to understand why, i have not this Hypothetical 80Mbits data transfert :slight_smile: .

Please Help !

Kind regards,

BooD

Hi @BooD, welcome to the forum :slight_smile:

What was the charger’s current capacity for the enclosure electronics? We normally use a 5V6A supply in the enclosure, which is more than many chargers supply.

The Technical Details of the Tether page have a stated resistance of 0.127Ω/m, which would be ~38.1Ω for 300m, so that’s as rated.

Assuming you’re running Companion’s Network testing, that’s an indication of ‘remaining capacity’ (beyond the ongoing operations, like the camera + telemetry streams) rather than ‘total capacity’, so it can depend on what else is running on your ROV. Network performance can also depend on the network capabilities and other ongoing network activities on your topside computer, as well as things like nearby sources of electrical noise and whether the tether is coiled up or unrolled.

Running our latest companion software (0.0.30), over ~3m of tether, I get

If I then use the webterminal (http://192.168.2.2:8088) to quit the running screen sessions (beyond the webui/webterminal, so basically turn off video + telemetry + other services):

for SESSION in $(screen -ls | grep "(" | cut -f2 | grep -v web)
do
    screen -S $SESSION -X quit
done

that then moves up to


(normal functionality can be restored by rebooting the Companion computer)

Bypassing the Fathom-Xs and tether with a 2m CAT6 ethernet cable directly from the Companion (Raspberry Pi’s) ethernet port to my computer, that then gets a touch higher to

Understandably a longer tether will have worse performance than my short test length, but testing with an ethernet bypass will at least give you some sense of the network performance your computer can achieve with the Companion. If that’s close to your current performance then it perhaps makes sense to try a different topside computer.

If that does help significantly then we can try to help figure out which part of the communication system is reducing the performance. If you’ve got an FXTI box my initial guess would be to try swapping out the internal ethernet to USB converter, or just bypassing it with an ethernet cable (between the internal Fathom-X board and your computer).

Hello Eliot,

Many thanks for your quick response.

Today, we update the companion computer and the autopilot to the latest version.

the USB to Eth adaptator was already bypassed.

We have connected the companion directly to the top side computer using an eth cable, and the speed was around 80 -85 Mbs.
So the Topside computer is not the issue.
but the speed is still 15-20 Mbs going threw the FathomX, tether connected, or Flying TP 1m long.

Hope this can help you to investigate further.

Thanks again for your time.

Hello,

This is a recurring condition we have also observed. For some reason, changing out tether worked for us in some cases, in other cases, changing out Fathom-X boards did the trick.

Is your tether stored on a spool?

Cheers,
E.

Hello Etienne,

Our tether is indeed stored on spool, 300m long, but when we skip the tether, we only have 10Mbs better.

And we also have replaced the Fathom-X board, topside and rovside.

Below the Process running on the companion, maybe something is burning resources …

Thanks !

BooD

What is the Rpi processor usage at?

If you plug the Rpi directly to your computer still poor speed?

This is what I got on mine. *Direct from Rpi to laptop

image

image

When I connect the Rpi to the topside computer directly, I have quite the same speed as you, around 70-80 Mbits