Home        Store        Docs        Blog

Channel map of light


#1

@jwalser, i am trying my rov with ardusub3.4 , everything is good now, but i can not get correct pwm light signal, i have trying every channel when i press joystick light brighter button on xbox one, in fact i don’t know the channel mapping of light signal, the following map is my light setting i confused how these channels mapped with pixhawk channels. any suggestions will be appreciated, thanks


#2

the light settings seems different with ardusub guide, is my qgroundcontrol too old?


(Jacob) #3

Are you using the simple ROV frame? All of the simple rov frames reserve channels 1-5 for motors. The lights will have to be on output pin 6 or greater.

the light settings seems different with ardusub guide, is my qgroundcontrol too old?

The ArduSub guide reflects the latest software. Right now that’s ArduSub 3.5 and any QGC from the last month or so.

-Jacob


#4

@jwalser , i have updated qgroundcontrol to latest daily build and ardusub to 3.5 and make sure have selected bluerov2 frame, but i still can not get pwm light signal output, all other pwm signal is ok(motor, leaking sensor, camera tilt), the following map is my setting, i have no idea why there is no pwm light signal
any ideas will be appreciated, thanks


#5

is there any additional settings to enable pwm light ?


(Jacob) #6

Channel 14 can only be used if you change the BRD_PWM_COUNT parameter. See here.

You should change the lights channels to 6 and 12.

-Jacob


#7

@jwalser, thanks jacob, in fact i am using bluerov2 frame not simple rov frame, i changed light one to channel9 and light two to channel11, they output pwm signal to aux1 and aux3. but i found another problems aux1 pwm signal positive width changed from 1.8~1.9ms when i press the light brighter key 14, but aux3 pwm signal positive width not changed, it remained at 1.8ms, this means only channel9 became brighter and channel 11 can not bacame brighter, is this a bug or still need some other setting?
suggestions appreciated! thanks


#8

@jwalser, if i use chnannels 6 and 12 which you suggested, i still can not get any output signal , so i switched to channel 9 and channel 11 and can get the output signal at least, can you share me the light setting of yours and i can try again, thanks a lot