Home        Store        Learn        Blog

Can not find WIFI network


Looks like this still doesn’t work.I can’t find my wifi SSID.

Did you follow one of the missing wifi SSID update processes, or did you just update directly from the web interface system page?

1 Like

I flash the image onto the raspberry pi SD card. The version is .0.0.27.

Are you sure your raspberry pi is within range of the wifi router (e.g. do you have a strong signal to that network on a mobile phone or laptop where your ROV is)?

Can you use the terminal over browser and post the results of running:

sudo iwlist wlan0 scan | grep -E 'Address|Quality|ESSID'

If possible run it a few times as the results can be different.

If you are still having an issue the software team may need to organise a call with you, because flashing should definitely avoid the bug that we found with the update process, so this will be a separate issue.

I connect the computer and the pi with a network cable. I am sure my PC is connect to wifi.And the signal is good,because we can communicate by email.

The version is ok,the connect is ok,the signal is ok. I use putty to log in to Raspberry Pi,and run the code.This is result.

Besides,I checked a lot of information about connecting to wifi .When i run some code ,all the code that have wlan0 can’t run. It shows that the pi don’t have such device. But pi 3B support wireless network.Maybe the wifi module is broken or there is no driver?

Another way is to share the network to the pi through the pc. I try it,after i turn on wifi sharing,pi still can’t go onmine,because it caan’t run the code sudo apt-get update.

Can you try running sudo screen -ls and seeing if the network-service screen session is there? If so, please run sudo screen -r network-service and post what’s in it.
You can press CTRL+a then d to detach from the screen session once you’ve got the info from it.

If the network-service is not there, please run

sudo -H -u root ~/companion/services/network/main.py

and post the error message that occurs.


This is result.

Seems like your wifi is disabled/not recognised. This stackexchange post suggests

  1. run sudo raspi-config
  2. use the up/down arrow keys to select Localisation Options (press Enter once highlighted)
  3. Select Change Wifi Country, and set the country you’re operating in
  4. Press the Right arrow key to highlight <Finish>, and press Enter
  5. Enter again to reboot
  6. Hopefully wifi works now

If that doesn’t work then hopefully our software team has some idea - otherwise you’ll likely need to try a different Raspberry Pi.

It may be worth running dmesg | grep WiFi to see if there are any startup messages related to Wifi being disabled or similar.

Update on this:

@jwalser says: