Can not find WIFI network

There is another way to update, using wired ethernet.
If you get the ROV connected to a topside router that have internet connection.
That means you have to build a small standard wired network with topside computer and ROV via a router.
Then status ends up with Wifi “pending” and Internet “Connected”

1 Like

Hi, @Richard1 When I upgraded the software to 0.0.26, I encountered the same situation as you, have you found a solution?

1 Like

Unfortunately I must tell you that this problem has not been resolved.I don’t know how to resolved it.
I think this may be a bug.Other versions will also have this problem.

@KCG/@Richard1 I can confirm this is a bug - it’s being worked on by our software team at the moment and should be fixed in the next companion update, that’s planned to come out within the next few weeks (hopefully quite soon).

Apparently this is a sub-case of a broader bug that got patched recently. There was some reasonably extensive testing done when that original fix was made, so it was expected that all the breaking cases had been handled, but it seems like there were a few that managed to slip through without being picked up.

Well,glad to hear this.Hope you guys update soon.
If you update the version, how do I know in the first time or will you send an update announcement in advance?

I’ll try to put a reply here once it’s released, but we’ll also do a forum announcement and pin it so everyone can see the announcement post for a month or so :slight_smile:

I have the same problem with a new vehicle setup. Could connect to wifi with the version of Companion that the vehicle came with but after updating to Companion 0.0.26 I couldn’t find any wifi networks.
I opened the Fathom-X Topside interface and connected the RJ45 from the Fathom-X into my router, and the same with the the USB-Ethernet converter to connect to the internet and update Ardusub.

If I roll back to 0.0.25 could I still have the same problem? I don’t want to open the electronics enclosure to flash Companion to the Pi if it’s not going to fix the problem.

The issue is actually with the update process, so if you flash the 0.0.26 image directly to the raspberry pi SD card then the wifi should be fine :slight_smile:

We’re aiming to release 0.0.27 in the next few days, which shouldn’t require opening the enclosure, but if you’re on a deadline then flashing an image more recent than 0.0.22 should fix the issue.

Thanks for the update. I can wait until 0.0.27 is released.

@Richard1 / @KCG / @gcelec

Please see the relevant instructions here :slight_smile:

A post was merged into an existing topic: Companion 0.0.27 Update!

Looks like this still doesn’t work.I can’t find my wifi SSID.

Did you follow one of the missing wifi SSID update processes, or did you just update directly from the web interface system page?

1 Like

I flash the image onto the raspberry pi SD card. The version is .0.0.27.

Are you sure your raspberry pi is within range of the wifi router (e.g. do you have a strong signal to that network on a mobile phone or laptop where your ROV is)?

Can you use the terminal over browser and post the results of running:

sudo iwlist wlan0 scan | grep -E 'Address|Quality|ESSID'

If possible run it a few times as the results can be different.

If you are still having an issue the software team may need to organise a call with you, because flashing should definitely avoid the bug that we found with the update process, so this will be a separate issue.

I connect the computer and the pi with a network cable. I am sure my PC is connect to wifi.And the signal is good,because we can communicate by email.

The version is ok,the connect is ok,the signal is ok. I use putty to log in to Raspberry Pi,and run the code.This is result.

Besides,I checked a lot of information about connecting to wifi .When i run some code ,all the code that have wlan0 can’t run. It shows that the pi don’t have such device. But pi 3B support wireless network.Maybe the wifi module is broken or there is no driver?

Another way is to share the network to the pi through the pc. I try it,after i turn on wifi sharing,pi still can’t go onmine,because it caan’t run the code sudo apt-get update.

Can you try running sudo screen -ls and seeing if the network-service screen session is there? If so, please run sudo screen -r network-service and post what’s in it.
You can press CTRL+a then d to detach from the screen session once you’ve got the info from it.

If the network-service is not there, please run

sudo -H -u root ~/companion/services/network/

and post the error message that occurs.

This is result.

Seems like your wifi is disabled/not recognised. This stackexchange post suggests

  1. run sudo raspi-config
  2. use the up/down arrow keys to select Localisation Options (press Enter once highlighted)
  3. Select Change Wifi Country, and set the country you’re operating in
  4. Press the Right arrow key to highlight <Finish>, and press Enter
  5. Enter again to reboot
  6. Hopefully wifi works now

If that doesn’t work then hopefully our software team has some idea - otherwise you’ll likely need to try a different Raspberry Pi.

It may be worth running dmesg | grep WiFi to see if there are any startup messages related to Wifi being disabled or similar.

Update on this:

@jwalser says: