Cabling between the Ping Sonar and PC

I’m Ludovic from France, sorry for my english.
Since 2 years I have a Ping Sonar on DIY survey boat, with out problem.

After 9 months without use, the sonar no longer sends info to the Pixhawk.
I ordered a new Sonar because I had to make a bathy quickly, but when I wanted to use it no return in the pixhaw.
In order to control the sonar I wanted it connected to my PC
Can you explain how to connect ping sonar to PC but it doesn’t work.
For the moment I use TTL to Serial RS232 converter (Sparkfun), Serial to USB (work find with other sensor), but impossible to connect.
Have you got more information for connect Ping Sonar to PC with out BLUART USB board.

Thanks for your help

Best regards


Hi @Ludo41, welcome to the forum :slight_smile:

  1. How is the sonar connected to the onboard computer? That’s normally done via a BLUART.
  2. Is pingproxy shown in the ‘Available Services’ on the System page of the Companion web interface?
  3. Which Companion software version are you using?

The connection to the PC should be the same as the connection to the onboard computer. The Ping Sonar communicates over TTL Serial (UART), so to connect it with a computer you need a suitable Serial to USB converter (like our BLUART). If your existing Serial to USB converter can handle TTL Serial then you can likely use that directly, without the TTL to RS232 converter in between.

I would also recommend double-checking our Ping Viewer troubleshooting steps.

Note that when the Ping Sonar is correctly connected to the onboard computer (Raspberry Pi) running our Companion software, the pingproxy service makes it accessible to Ping Viewer from the topside computer, and if Ping Viewer is not being used it sends distance messages to the autopilot board (Pixhawk) as a fallback option.

hi @EliotBR
Thanks for your reply.
I buy FDTI Cable for TTL to RS232 and know I can connect my Ping 1D sonar with PC.
My first sonar have a problem, impossible to connect in pingviewer and when I flash firmware, it’s stop at 22%:

The 2nd sonar (buy with 2.38 firmware) connects to the PC but not on my Pixhawk Cube Black.
In order to have a fixed port speed of 115200 baudt I launched the Firmaware flash from PingViewer, but after 1 hour, I have alway the progress bar who turn:

I can disconnect? or it’s dangerous for Sonar?

Best regards

Firmware update OK on new Ping Sonar, connection at 115200 on PC ok.
But, once connected to the Pixhawk I get nothing in MissionPlanner, the sonar and port settings are good in the Pixhawk, I don’t understand.

The only thing that intrigues me is in Pingviewer, when I launch it, it looks for the port and shows me this screen:

I click on the device, I receive data (the sonar is in a water bottle), if I open the device manager I have this screen with a red dot, is that normal?

Best regards

I’m not sure what you’re saying here - the Pixhawk doesn’t have sonar or port settings, can you please describe how you’re connecting and configuring things?

In a standard ROV setup the default setup is
Ping Sonar → BLUART → Raspberry Pi 3B (Companionpingproxy) → Topside (Ping Viewer)

If no connection to Ping Viewer is made then it falls back to
Ping Sonar → BLUART → Raspberry Pi 3B (Companion → pingproxy → pingmav) → Pixhawk → Topside (QGroundControl)

Yes, once you’re already connected to the device it’s considered to be ‘busy’, and it’s not possible to make an additional connection to it, which is what the red dot signifies :slight_smile:

Hi @EliotBR
My connection:
Ping Sonar → Cube Black Pixhawk TELEM2 → Topside (Mission planner)
On my board TELEM2, it’s Serial port 2:

  • [SERIAL2_PROTOCOL] = 9 (Lidar)
  • [SERIAL2_BAUD] = 115 (115200 baud)
  • [RNGFND1_TYPE] = 23 (BlueRoboticsPing)

This configuration worked perfectly for 2 years, but last week no more return of the sonar in Mission Planner, once the boat in the water, I had not done a test out of the water).
So I bought a Ping Sonar. But once plugged in (test out of the water), still no return in Mission Planner.
I then bought an FTDI TTL to USB cable to test my 2 sonar on a PC, the new one worked without problems but not the old one.
I ended up opening the old one (3 days after the water came out). No LED on, I did a command line firmware update that failed. I tried again yesterday an update in 2.37 (115200) and it worked.

Finally by feeding the sonar from the +5 volt output of my regulator and not by the serial port TELEM2 I manage to have the return of my sonar in Mission Planner.

Today, when I wanted to set up the boat to test it on Monday, I noticed on my old sonar that the rubber resin on the sonar cable pass had come off the aluminium tube.
Is it possible that a tiny amount of water is infiltrated and which have court-circuited the serial card port making power supply through this port impossible?

How to repair this resin?

Thank you

Huh, I wasn’t aware there was a direct Ping Sonar rangefinder option in ArduPilot. It’s seemingly from before I started at Blue Robotics, and doesn’t seem to be mentioned in our documentation (which is a situation we should improve/fix).

Ok, good that you seem to have found a workaround for your issue at least :slight_smile:

I’m not sure - do you have access to a multimeter? You could potentially probe the port without the sonar connected to see if it’s providing an output at all or if the power pin is fried/damaged.

I’d recommend you contact for this - I’m not sure what we normally suggest when the epoxy on a potted penetrator has failed. If the device is still working then you may be able to clean off the electronics with some isopropyl alcohol and replace the penetrator (and possibly replace the cable too, if it’s starting to corrode), but if the PCB or the components on it are corroding then depending on the damage you may need to replace the PCB or the entire device.