Home        Store        Learn        Blog

Bluerov2 heavy Lateral left and Lateral right is not working


I have now test my Bluerov2 heavy in a pool and i discovered that Bluerov2 heavy will not go Lateral left or right anymore. the bluerov2 was worked fine before I upgraded to Heavy.

Everything works except the Lateral,if i use the left joystick ,Forward and Reverse is working,but not Lateral When i try to use lateral left or right the bluerov2 heavy standing still,because two of thruster is going wrong way.

Is it a bug in Bluerov2 heavy parameter file?

The motor directions are controlled by the MOT_n_DIRECTION parameters, which are not present in the file, so they should not be changed when you load the file.

Did you happen to remove any of the existing ESC cables from the pixhawk while you were doing the retrofit?

I have not remove any of the existing ESC cables from the pixhawk when i did retrofit.

Ok, When do you need to use the ROV again? I will have some software updates very soon with motor test in QGC that will make it much easier to find the problem.

Just trying to test bluerov2 heavy,so I can wait for new software update.

Maybe I have mounted the Thruster in the wrong place (the front Thruster shall be back and back Thruster shall be front)

I have seen one problem before like this resulting in no yaw. The easier fix for this situation is to switch the ESC cable on the pixhawk than to move the motors:

I’m not sure if your situation is the same. The situation you describe could be like the one in the picture, but if you swapped 2 and 4, then lateral would not work any more like you describe (or 1 and 3). Try the motor direction setup again will be the easiest first step. Again, the exact problem will be easy to determine with an update. It will be ready in less than one week.

I think I found the problem,thruster 1 and thruster 3 is wrong.
Thruster 1 shall be in front and thruster 3 shall be in back,mine was the opposite :grinning:

Will test it in pool tomorrow

Another thing when you activate roll/pitch toogle, A button has not voice? (like depth hold mode,manual mode,stabilize mode have)

Everything works now :grinning: