Home        Store        Learn        Blog

Bluerov joy_node

I am running this github repository https://github.com/patrickelectric/bluerov_ros_playground from patrick
but when i run gazebo_teleop it doesnot work it gives me this error which i have put it on the bottome please can someone check why i am getting this error, moreover i am using ROS kinetic Edition and when i run the ps3 controller it doesnot work because of joy_node plzz can someone check

Hi,

Do you have joy package installed with all necessary packages/dependencies ?
Try to search for joy_node or run joy package examples to find out what is going wrong.

I install this package


I tried to catkin_make in both with catkin_ws and inside bluerov_ros_playground.
But it still give me the same error. Is there any specific library which i should use for joystick drivers. I have searched alot on google but not able to resolve the issues.
Can you please explain how should i catkin_make the joystick_drivers
Thanks for replying

I have success fully resolve my issue by following your instruction but i am also getting another Error I dont know why please can someone check it


Moreover, I am using an PS3 controller to control the Bluerov gazebo simulation plz can someone check and let me know
Thanks

Hi,

Enable the verbose mode do debug what is going on with gazebo