BlueOS doesn't recognize my 4K Camera

Hello, I don’t know what do I have to configurate in order to the BlueOS recognizes my camera.
The camera model is e-CAM130_CURB and it’s connected via FPC cable to a Raspberry Pi 4.
When I access to 192.168.2.2/autopilot/video-manager, it says No video-devices available.
Maybe I have to install an extra driver? Or configurate something in 192.168.2.2:6020?

Hi @Gabriel1, welcome to the forum :slight_smile:

From a quick search of the product, there are a couple of potential issues here:

  • The camera requires a custom driver
    • If you haven’t already installed that then presumably it won’t work
  • The camera only outputs a raw UYVY stream
    • BlueOS is currently only advertised as working with H264-encoded streams, and that’s all that will show in the standard version of the video manager
      • As it turns out, the latest BlueOS beta version, with Pirate Mode turned on, has support for YUYV streams, so can potentially support your camera’s output if the camera itself is able to be detected
    • UYVY is a raw (unencoded) format, which (especially at high resolutions) can take a significant amount of bandwidth - that may not work for setups with long tethers or other causes of poor network capacity (although that shouldn’t stop the camera from being detected as a video device)
1 Like

Hi. I already installed the custom driver.
If BlueOS Recognizes the camera, it should appear automatically in the video manager? Or do I have to manually configure something in order to see it?

Was this done via ssh, or through the BlueOS web terminal? If it was done through the web terminal and you didn’t use the red-pill command then you may have installed it in the core docker image, in which case it would be deleted next time the core was restarted.

I spoke with our software engineer who has most recently been working with the video manager, and was told if you have pirate mode enabled and the camera is detected then it should appear automatically in the video manager (assuming you’re running a recent BlueOS beta release). If pirate mode is disabled then only cameras with H264-encoded streams show up, which excludes your camera.

Note that camera detection and successfully being able to set up a stream are two different things. The camera manager at the moment is capable of setting up a YUYV stream, but it likely needs an update for it to accept and properly handle a stream with UYVY encoding (even though they’re functionally very similar encodings - the information is just in a different order).

For installing the drivers, I flashed a SD card with BlueOS then installed the latest Beta version.
Then, I followed the guide from the developer that I attached. From page 6 to 9.
e-CAM130_CURB_Developer_Guide_Rev_1_1.pdf (380.7 KB)
The commands are done in a PC with Ubuntu