BlueOS Cockpit Issues

Hey BlueOs I seem to be having this issues with cockpit that says

"It looks like something went wrong while loading Cockpit. "
“Resetting the settings can solve the problem.”

button: Reset Cockpit settings

hitting the button doesn’t seem to fix the problem, are there other ways to solve this?

Hi daniel!

Which version of Cockpit are you running?

Have you been able to run Cockpit before or the problem appeared right after installing it?

Hey Rafael,

We are running BlueOS 1.2.6, Cockpit 1.0.0-beta17 & Zerotier 1.12.2. The problem is experienced when running remotely. Zerotier shows it’s connecting in the control panel.

With local IP it starts up, see below.

Which global address are you using when connecting remotely?

If you don’t remember, you can open Cockpit (even with the reset problem), open the browser inspector, go to Application and check the local storage variable for “cockpit-global-address”.

I may have looked in the wrong however I couldn’t find the variable “cockpit-global-address”.

Not sure if this shows the information you’re looking for. We first used the default address, which was blueos.local or local.blueos. We had problems with the IP camera RTSP URLs and were advised to change it to the same IP address range that the cameras used. We have local and remote users/developers.

The exact name is actually “cockpit-vehicle-address”. My bad.

When done locally, it shows the local IP we assigned it in the image above. When done remotely, it shows the managed IP provided by Zerotier. It works locally but not with the Zerotier remote IP. Is there a configuration we’re missing perhaps?

Can you get a print of the console and the general configuration menu when the ZeroTier IP is assigned?

If you have ZeroTier running on your ROV, it should just work.

I actually have one connected right now. Just installed the ZeroTier extension in the ROV, opened a network in my ZeroTier account, joined both the ROV and my PC in the network and connected using the IP of the ROV (remember to remove the /16 from the end of the provided IP).

Well this is what I can see on the console( I don’t Think it’s relevant to the error)

TronLink initiated
       Failed to load resource: net::ERR_CONTENT_LENGTH_MISMATCHUnderstand this error
main.d8964f48.js:806 Error scanning for services: Error: timeout of 10000ms exceeded
pushNotification @ main.d8964f48.js:806Understand this error
       Failed to load resource: net::ERR_CONTENT_LENGTH_MISMATCHUnderstand this error
       Failed to load resource: the server responded with a status of 404 (Not Found)

In previous Topic You mentioned to go to Application>IndexedDB>Cockpit-SystemLogs, this is what I could get from there I don’t know if this is relevant because i can’t decode any error statements:

"Cockpit (Jun 02, 2024 - 18꞉38꞉07 GMT+1).syslog" 1. {initialDate: 'Jun 02, 2024', initialTime: '18꞉38꞉07 GMT+1', events: Array(312)}

  1. events: (312) [{…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…},…]
  2. initialDate: "Jun 02, 2024"
  3. initialTime: "18꞉38꞉07 GMT+1"
1 "Cockpit (Jun 02, 2024 - 18꞉39꞉33 GMT+1).syslog" 1. {initialDate: 'Jun 02, 2024', initialTime: '18꞉39꞉33 GMT+1', events: Array(73712)}

  1. events: (73712) [{…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, {…}, , …]
  2. initialDate: "Jun 02, 2024"
  3. initialTime: "18꞉39꞉33 GMT+1"
2 "Cockpit (Jun 02, 2024 - 18꞉39꞉37 GMT+1).syslog" 1. {initialDate: 'Jun 02, 2024', initia

It seems to me that your system is not being able to even load the Cockpit application. “Failed to load resource” problems happen when the browser can’t access the static files.

Are you serving Cockpit on your machine, or you’re trying to access it remotely? If remotely, do you have a good connection to the source? Those errors are actually from BlueOS. It seems to me that it is not working properly.

Also, you can check the events of the logs to better understand your problem.

Hey Rafael, initially when it was installed, it worked just fine and then stopped. The RPi is used locally and remotely (in the workshop). Keep in mind that we’re not operating it remotely and locally. Just for development given the team is remote. Not sure is this is part of the problem. We did changes in Cockpit when doing the RTSP cameras with the IP address as seen earlier.

My suggestion would be to run Cockpit locally, as it was in developers mode (there are instructions in the repository README), or run the standalone version (available in the repo releases page), and try to connect it to the remote vehicle. This way you don’t have BlueOS in the middle and the logs will be more clear about the issues you’re having.

Hi Rafael, attempts to install Cockpit electron on the topside computer have been unsuccessful. There are many dependency problems when installing the required npm, vite etc on Ubuntu 24.04.

I installed the exe on my laptop and entered the remote IP from Zerotier. It appears to connect. I’ve attached the logs.
Cockpit (Jun 26, 2024 - 09꞉03꞉30 GMT+2).syslog.txt (1.9 MB)
Cockpit (Jun 26, 2024 - 08꞉59꞉54 GMT+2).syslog.txt (288.3 KB)

I am unsure if this helps given the Cockpit install is on a remote Windows PC when we need it on the local top-side Ubuntu PC however it appears I can connect through the remote PC with the standalone version. The problem remains the inability to connect to the Cockpit extension.

So far, we can connect to BlueOS using the remote Zerotier IP and we can connect to BlueOS via a standalone version of Cockpit on my laptop using the Zerotier IP.

UPDATE/EDIT: I installed Zerotier on the topside computer and can view Cockpit remotely on it. See image below. I still can’t view it on the two remote computers that are doing dev work.

Not sure how but it has all sprung back to life. The problem solved itself somehow. Thanks for the help, much appreciated.