BlueOS 1.0 BETA testing

hello everyone, I’ve been testing the beta versions for a few weeks now and it’s impressive at the speed it’s going but, I have a problem this beta version is supposed to work on raspberry 3b+ and pi 4, but I can’t get it to work on my raspberry pi 4 b, I install everything without problems, but apparently neither the camera nor the pixhawk recognized me, I tried several versions of the beta, but it does not solve it, I am attentive to any help, thanks

Hi @seba, welcome to the forum :slight_smile:

Glad to hear it! :slight_smile:

Not sure what’s happening there - as far as I know we haven’t had any issues with RPi 4 not working.
A couple of questions:

  • Are the camera and pixhawk not being detected by BlueOS, or are they not appearing in QGroundControl at the surface computer?
  • Are the surface computer network settings the same as when you’re using it with the RPi 3B+ (MAVLink and the camera stream both go via UDP, which may be blocked on your computer by a firewall)?

Hi @seba,

We did a new image release for 1.0.0-beta.14, you can download it from the release or from our documentation.
This image is a release candidate for the Linux OS, let us know if you find any problems.

  • it is the BlueOS that does not recognize the devices and therefore neither does Qgroundcontrol,

  • The problem does not happen to me with the raspberry pi 3b+, using the same computer and configuration, so I think it may be a problem with the raspberry pi 4, which requires some manual configuration or something like that

I was running into similar issues and I looked deeper into it. I have 2 RPi 4 and one works and one doesnt. One of them is 2GB in RAM (the one that works with USB devices) and the other is 4GB in RAM (the one that does not detect any USB devices). When I do a clean install of standard Rasbian, the Pi detect all the USB devices perfectly fine on both model.

Hope this insight helps.

If I’m remembering correctly there were some issues with a previous image not being able to properly detect USB ports, but I believe that was fixed a while ago. It should hopefully work to flash on the new image Patrick linked to (instead of updating to it), but please let us know if that doesn’t solve the issue :slight_smile:

Hello!

You are right, I just tested it with new firmware burned (not updated from webUI) and it worked flawlessly!

Thanks!

1 Like

Hi:
Actually I don’t know very well what the underlying problem was, but with the latest beta 15 update, I solved the problem, and now it recognizes the USB elements without any problem, thanks for the help

1 Like

2 posts were merged into an existing topic: QGroundControl Not Recording Video

B.E.T.A has ended, check out BlueOS stable public release

1 Like