BlueOS 1.0 BETA testing

Hello,

I am currently setting up companion 1.0 on a raspberry pi 3 to see if I can set up multiple video streams using two cameras. Going through the process on install/configuration page, I was able to stream one video in Qgroundcontrol. But when trying to stream second camera through vlc, I cannot get it to connect. I tried through both beta 5 (sd image I downloaded) and with newest beta 7.
This photos are what I set the cameras ip adresses to (video1 is connected to QGC, while video 2 is what I want connected to vlc player):

1 Like

And these are a few inputs I tried to vlc to connect to second camera:
image

Hi @Jnyberg,

Could you try port 5610 for video2? The previous Companion used 5601 for audio - I’m unsure whether that port conflict is still there.

If that’s not the issue then I’m unsure what is (perhaps the VLC setup?) - I’ve asked the software team in case there’s any extra info they can provide :slight_smile:

I’m away at the moment, so can’t do testing on my own setup for the next couple of weeks.

1 Like

When streaming two or more cameras to vlc on the old companion it only worked using even port numbers 5602, 5604, 5606 etc. I dunno why…

1 Like

It should work with any valid udp port, not necessary even numbers.
But it appears that VLC only works with even numbers.

1 Like

Hi @Jnyberg,

If you want to make it work with VLC, the easiest way is to use a SDP file.

c=IN IP4 192.168.2.2
m=video PORT RTP/AVP 96
a=rtpmap:96 H264/90000

Where PORT should be the stream port.

2 Likes

Tried the even port 5610, no change. Then made the SDP file with same port number but to no avail either. Even tried different port numbers like 5601/5604/5606 on SDP file. Are there any other options to test?

Hi @Jnyberg,

You can configure the video stream on QGC to use the other port to see if the stream is working.
Do you have configured your computer with the IP 192.168.2.1 ? You could try to use 0.0.0.0 on the sdp file.

1 Like

Hello @patrickelectric . So an update to my situation is that I have double checked through QGC that both cameras are hooked up and streaming, both cameras work through their port when changing the port on QGC. My computer has an IP address of 192.168.2.1 and the companion has IP address of 192.168.2.2. I then without changing anything else, tried the sdp file using the IP address you recommended of 0.0.0.0. I am hoping that is what you were trying to recommend doing, if not let me know if I am not setting something up right.

Hi @Jnyberg,

I would recommend to reinstall, update or install a new version of VLC, it should work without problems if QGC is working to receive both video streams.

1 Like

I see that the latest release is 1.0.0.beta9.
Is it created a image file for this one, or any of the other versions after beta5?

@patrickelectric that worked thank you. I had newest version but deleted and reinstalled VLC like you said and it did the trick. Got both cameras to work so thank you so much. There is a significant delay on the second camera connected to VLC but I will continue to work on that now.

1 Like

That’s likely a caching issue, as discussed here:

1 Like

I believe we were planning to change to an auto-building process that creates a new image for each version when it gets released. I’m unsure whether that’s completed yet, so have asked internally, and will update the docs if it has.

In the meantime, it should still work to install 1.0.0.beta5 and just run the update process to get to 1.0.0.beta9 :slight_smile:

Hello,

I’m in the process of testing the new Beta Companion.

My use required me to make changes to the host system. I am using the Raspberry Pi to perform some actions that are not related to the ROV.

I cannot find any documentation as to the password for ‘ssh pi@192.168.2.2’. Is there a password for the PI user?
If so, where would I find it?

Thanks for your help.

Mark Kozikowski

Hi,

Is the default raspberry password, raspberry

thanks,

hello everyone, I’ve been testing the beta versions for a few weeks now and it’s impressive at the speed it’s going but, I have a problem this beta version is supposed to work on raspberry 3b+ and pi 4, but I can’t get it to work on my raspberry pi 4 b, I install everything without problems, but apparently neither the camera nor the pixhawk recognized me, I tried several versions of the beta, but it does not solve it, I am attentive to any help, thanks

Hi @seba, welcome to the forum :slight_smile:

Glad to hear it! :slight_smile:

Not sure what’s happening there - as far as I know we haven’t had any issues with RPi 4 not working.
A couple of questions:

  • Are the camera and pixhawk not being detected by BlueOS, or are they not appearing in QGroundControl at the surface computer?
  • Are the surface computer network settings the same as when you’re using it with the RPi 3B+ (MAVLink and the camera stream both go via UDP, which may be blocked on your computer by a firewall)?

Hi @seba,

We did a new image release for 1.0.0-beta.14, you can download it from the release or from our documentation.
This image is a release candidate for the Linux OS, let us know if you find any problems.