BlueBoat network adapter issues

I am having network issues with my blue boat. After I have gone through the complete software guide I have run into an issue where I need to be connected to the base station using both the usb c cable and wifi. If either connection is not up I get a disconnected error saying the backend is offline on blueos.local… Has anyone else experienced this or have an idea of how to trouble shoot? The main goal here is to be able to access the internet on my computer while also being connected to the boat but I cannot seem to find the right combination to make this work. The boat and base station are up to date (BlueOS 1.2.6 and Autopilot firmware 4.5.4) and I am using a M2 MacBook Pro running Sonoma 14.5. The base station has no issues connecting my wifi network to download updates and extensions.

1 Like

Does this happen only when browsing to blueos.local? If you navigate to the IP address of one of the interfaces, like do you have the same “backend is offline” message?

Can you open Terminal and run dns-sd -G v4v6 blueos.local and provide the output here?

I actually can’t connect to the boat using the ip address (even using the two connection method). Using the blueos.local I get the following when using both usb c and wifi:

This is what I get when I am only using usb c or the wifi connection:

Hi @jwenger -
If you can only reach BlueOS at blueos.local, something is likely not correct with your network settings.

Please verify that when plugged in only via USB-C, your (USB to ethernet) network adapter is configured to give you a static IP of with subnet mask You should then be able to reach BlueOS at! If your default Mavlink Endpoint has not been adjusted, you will get a connection automatically in QGround Control.

When connecting to the BaseStation WiFi network, you need to manually configure your Wifi Adapter IP address to the same values - but this will prevent you from getting a DHCP address from a subsequent WiFi network connection (an annoyance of MacOS.) This is why I primarily use the USB-C connection, as going in to change the setting back is a bit of a pain.

I hope that fixes it for you!

If it doesn’t, please verify you can reach the BlueBoat radio in your browser at If you cannot, you may actually be reaching BlueOS via WiFi connection to your local network, and still need to follow the BlueBoat to BaseStation pairing instructions.

Hey @tony-white ,

I have gone through the base station to boat pairing a few times just to confirm it was done… At the moment, when I connect solely with USB C (with properly configured ip and subnet) I am unable to reach or However, when I open QGround control I am receiving accelerometer, gps and compass data from the boat but not the full set of system parameters.

Is there some way to totally factory reset the boat and base station to start from scratch? I wonder if some network properties have been changed that I am not seeing.


Hi @jwenger -
If you can’t reach 2.2 or 2.4, but do get data from the boat when connected, that is very strange! It suggests you’ve changed the default IP address of these devices, but still have a mavlink endpoint that is targeting your computer’s IP of .2.1? I’ve only seen partial data in QGC without parameters loading when the subnet mask was not set correctly…
Are you sure the data you see in QGC is live? Could you be receiving it via some other method, such as the Raspberry Pi in the Blue Boat’s connection to your local WiFi network / ZeroTier?

To reset BlueOS, simply download the latest stable image and flash your SD card, then follow the setup wizard when you reinstall and connect to the boat in your web browser, at or blueos.local. You can refer to this post for resetting radio configuration instructions.