BaseStation Disconnection Over WiFi


I’m having trouble with my connection to the BaseStation over WiFi. I wanted to switch from the USB-C ethernet connection to WiFi so I could better position the BaseStation, however, once I’m connected, anytime I try to access blueos.local the BaseStation WiFi disconnects. Here’s what I’ve done so far:

  1. I’ve confirmed that the BlueOS (1.1.1) and firmware (4.2.3) are up to date using the USB-C ethernet connection.
  2. I’ve tried accessing blueos.local on different devices to rule out a device-specific issue.
  3. I’ve also confirmed there are no other devices connected that could be causing an IP address conflict.
  4. I’ve tried with a completely different laptop going through all the software setup steps to no avail.

Has anyone else experienced this kind of issue? I’m reaching out to see if there might be a known fix or if there are additional troubleshooting steps I can take to diagnose and resolve this problem. Any insights would be greatly appreciated!

Thank you!

Hi Peyton,

Are you using a Windows PC to connect to the BaseStation? I’m not sure if this is your issue, but I’ve had issues in the past trying to connect to a WiFi network that does not have Internet using a Windows PC. Windows doesn’t seem to like connecting to a network that doesn’t have Internet, and will constantly drop the connection in favor of other networks saved in your WiFi list. What I’ve had to do in the past is go through each network on the WiFi list and uncheck “connect automatically.” Then, I set the non-Internet WiFi network to connect automatically. This has helped me in the past. At times, it was so frustrating using Windows that I just switched to using a Raspberry Pi instead, which had a much more stable connection.

Anyway, that’s my two cents.


Hi Peyton -
I’d echo Gabe’s thoughts, Windows can be a pain sometimes!
Beides blueos.local, have you tried to connect to the BlueOS at the IP of the boat Raspberry Pi? This should be configured as You can reach the boat radio at, and the basestation radio, if you are successfully connected to its network, would be You may need to configure your WiFi adapter to use the static IP address, as the guide details, but not just for the ethernet connection. Hope that helps! Getting the base-station up high is definitely the best way to boost range, besides a directional antenna & more antenna height on the boat side.

Hi Anthony and Gabe,

Thanks for the advice, I tried using a different computer with Ubuntu 22.04.3 LTS and encountered the same issues unfortunately. I’ve tried different positions and areas with the BlueBoat and the BaseStation while referencing the updated guide, however I consistently get disconnected immediately or soon after trying to access blueos.local or, and only if I’m able to connect to BlueOS at all (maybe once every 15-30minutes for just a few seconds). I tried a fresh install of BlueOS on a different sd card, went through all the Software Setup steps until trying to connect to blueos.local, however I intermittently get disconnected and reconnected from the BaseStation. This repeating connect/disconnect even occurs over ethernet, but tends to stop if I let it do that for about 30-60 minutes. However, BlueOS itself will repeatedly disconnect making it difficult to have a stable connection to the BlueBoat for software updates, calibrating, and missions.

For some context, I had these issues when first getting the boat and ended up getting it to connect, update, and calibrate with a lot of patience/luck. I originally thought I had so much trouble due to being in a parking lot in-between two buildings. However, during the test run and subsequent missions on the water, the connection was quite stable. Now I wanted to modify the setup since I want to add a camera and ML model for an object detection project so I put in a Raspberry PI 4 Model B with 8GB RAM and a 128GB SD Card with faster transfer rates. Unfortunately, I’ve gone out to the place we had our test run and am encountering the same issues. Additionally, the light on the boat stays on during this process (originally it would flash during setup, however during the successful test run it would only stay on persistently). My battery setup are two 4S8P Battery Packs (one in each hull) and they’re rated to 14.8V, 20.8Ah and they worked for the test run before the board and sd card switch.

Additional measures I’ve taken include disabling Bluetooth and Personal Hotspots. The antennas are securely fastened and properly oriented towards each other.

I’m reaching out to see if anyone else has had similar experiences or if there’s something I might be missing in the setup. Any additional suggestions or troubleshooting tips would be greatly appreciated.

Thanks in advance for your help!


Sorry you’re continuing to struggle Peyton. I suspect you are not ever connecting to the BlueOS webpage - the browser will cache a version that loads, but then immediately says DISCONNECTED at the top of the page when it can’t reach the host device.
Have you tried pinging or Those are the addresses for the Pi in the boat and the Boat radio - if you can’t ping them, you aren’t successfully connected to the BaseStation radio at
You can run “ping” from the windows terminal. Sorry for the hassle!

Hi Anthony, I’ve tried pinging before and most of the time cannot get a response, although rarely it will respond and the blueos.local webpage can remain open for a couple minutes with me interacting with it. When I begin to try calibration through QGroundControl or any sort of interaction with the boat itself, it will disconnect. I can get messages from QGroundControl saying something like “command not received/sent” for whatever I was trying to calibrate and there can be layers of popups effectively telling me it disconnected from the boat and it cant interact with the autopilot parameters/variables.