Home        Store        Docs        Blog

Ardusub initial setup


(Jonathan Santrovitsch) #21

Jacob,

I set the right IP 192.168.2 1 on QGC, but no video. You have the image of SD card of raspberry to send me or put on cloud to download. I made any times the instalation of raspberry pi and check the setup of parameters an IP’s but not work. I have telemetry, but no video of raspberry pi stream. On terminal of Putty, i send the command "sudo screen -r video, and the answer is ok, “Playing”.

 

I don’t know what I do to solve the problem.

 

On the page of ardusub, for setup the raspberry, the link of repository not have the image of sd card to download, just have the information to do by “manual”

Jonathan


(Rusty) #22

Hi Jonathan,

I see from your previous pictures that you have added a comm link on Port 5600 (Capturar1.png). I think the comm ports in QGC are only for MAVlink communication. You should remove that as it will get in the way of the video connection.

-Rusty


(Jonathan Santrovitsch) #23

Rusty,

I set my “start_video.sh” like attached. But no video on QGC. The stream is set to port 5600. It’s right, because the mavlink is set to 14550? My laptop run windows 7. I can see the telemtry, change the parameters of pixhawk, but no video. On desktop of RPi, i can see the video if remove “-- no preview” from “start_video.sh”, but on QGC not. It’s possible use other program to check if receive the stream of video on windows?

Jonathan



(Jacob) #24

For the video link, you should not have to set up anything in qgc. That means, no comm link configuration necessary, and you don’t want any comm links pointing to port 5600. When you open qgc, do you see any window that says “no video” when you click on the paper airplane icon?

-Jacob


(Jonathan Santrovitsch) #25

Jacob,

Yes, I remove all comm link. I see the window that says “no video” on paper airplane icon.

Attached more print of QGC. In marked yellow is the telemetry working.

Jonathan




(Jonathan Santrovitsch) #26

Jacob,

It’s possible my QGC is the problem? You have a link to download QGC that you use? I download my QGC from this link:

https://donlakeflyer.gitbooks.io/qgroundcontrol-user-guide/content/download_and_install.html

From “Daily Builds”

Jonathan


(Jacob) #27

If you are using a prebuilt qgc, you can try changing the port to 5000 instead of 5600 in the start_video script. (5000 is the old port used for video, they have changed it to 5600, I don’t know whether the build you are using is 5000 or 5600).

Otherwise you can build from source using the BR fork of QGC: https://github.com/bluerobotics/qgroundcontrol
This one uses port 5600.

-Jacob


(Jonathan Santrovitsch) #28

Jacob,

I try to build the QGC from the source bluerobotics, but I have an error on QT Creator that I cannot solve. It’s possible You share with me the QGC compiled for windows somewhere like GDrive, Dropbox, etc?

Attahced is the error that I get on QT Creator. I install “visual studio”, “gstreamer” in Windows 7, and get the source from the repository that you pass me, but no way!

Jonathan




(Rusty) #29

Jonathan,

I’ve also had trouble getting the video streaming working on Windows. I’m going to ask around among the QGC developers and see if they might know how to resolve this.

I compiled is on Windows and was not able to get the streaming working.

I’ll let you know how it goes.

-Rusty


(Jonathan Santrovitsch) #30

Rusty,

Tanks! Just more one question. How other alternatives we have to use Ardusub with the camera of raspberry? MAC IOS? Android? or may be Mission planner?

 

Jonathan


(Rusty) #31

Jonathan,

I have tested on Mac and Linux with good results. I haven’t tried on Android but it should work.

The mission planner application cannot be used to view the video.

-Rusty


(Jonathan Santrovitsch) #32

Rusty,

I will to try this to check if work:

If not work on the QGC, will work in separated window in the Windows pc.

Other issues, you think in use a optical flow sensor to help with the dynamic position if have some object underwater like a boat? This will help to stay on position for inspection, for example.

Jonathan



(Rusty) #33

Hi Jonathan,

Okay. Good find. That will hopefully work. I’ll give it a try too when I have a chance.

One developer on our Gitter chat page is working on putting optical flow on the ROV. He’s been talking about it recently: http://gitter.im/bluerobotics/ardusub

-Rusty


(Jonathan Santrovitsch) #34

Dear All,

I can start the video on a window, in windows 7, 8 and 10, but not on a QGC. I make a .bat on windows with:

@echo off
cd C:\gstreamer\1.0\x86_64\bin
gst-launch-1.0 -e -vvvv udpsrc port=5600 ! application/x-rtp, payload=96 ! rtpjitterbuffer ! rtph264depay ! avdec_h264 ! fpsdisplaysink sync=false text-overlay=false

And my start_video.sh on RPI:

#!/bin/bash
clear
raspivid -n -t -w 640 -h 480 -fps 30 -b 25000000 -o - | gst-launch-1.0 -e -vvvv fdsrc ! h264parse ! rtph264pay pt=96 config-interval=5 ! udpsink host=192.168.2.1 port=5600

It’s not the best way, because don’t work the “HUD”, but is a temporary solution at we have a final solution of the issue of UDP for QGC on Windows. It’s possible change the resolution on “-w and -h” of the script"video_start.sh" on RPI

Jonathan


(Rusty) #35

Jonathan,

Excellent! That’s great news. We’re looking into the video streaming on Windows and hope to figure out a solution soon. This is a good validation that gstreamer works in Windows.

Thanks for sharing.

-Rusty


(Kevin) #36

Jonathan,

Trying to follow your lead here. How did you manage to log into the RPi GUI to create the start_video.sh file? I tried this tutorial and got a bunch of errors when I tried to connect. https://www.modmypi.com/blog/remotely-accessing-the-raspberry-pi-via-rdp-gui-mode


(Kevin) #37

Nevermind, I went down the rabbit hole last night and installed the LXDE GUI last night. Fun stuff! I created the start_stream.sh file and edited it with gedit. However, I can’t seem to get it to run when I get back out and try executing it with Putty. Anything special to run shell scripts?


(Rusty) #38

Hi Kevin,

When you execute the command in Putty it should work fine but will exit as soon as you close the putty shell. You can run it in “screen” to prevent that. You would do that like this:

screen -dmS stream /home/pi/start_stream.sh

Also, make sure you make the shell script executable. You can do that like this:

chmod +x start_stream.sh

Last, the old video stream will still be running since it starts at boot by default. To stop it, you can run this command first:

sudo screen -X -S video quit

If you want to stop it from starting in the first place, you can edit the file /etc/rc.local and comment out the line that has the “start_video.sh” script in it.

-Rusty


(John) #39

Did anyone figure out the video in QGC in windows yet? I have been trying a couple of attempts with both gstreamer and VLC but keep hiting wall on baudrate or protocol version error on connection to QGC.

  • John

(Paul) #40

I believe Kevin has been successful in getting it to run on his BROV2 using the latest daily build of qGround Control. You might try checking the ArduSub gitter page here: https://gitter.im/bluerobotics/ardusub