Home        Store        Learn        Blog

10 Mbit speed setup

Greetings!
Is there a way to force ethernet port on raspberry pi for 10 Mbit speed? If not, can i install aditional software via terminal so i can set it by myself?

Assuming you’re wanting to limit it to 10Mbps, ethtool may be helpful. This reddit comment mentions a few different utilities.

Note that you might have latency issues, especially if you’re transmitting a 1080p video stream along with the telemetry data and controls (or more on top).

Tnx, I am aware of latency issues. I tried to download ethtool via raspberry pi terminal, but without success. Before that I connected to internet via pi’s wifi. It seems like i cant download ethtool packet to raspberry. Can you download aditional software to Raspberry at all or it is locked for downloads?

If you successfully got the RPi connected to the internet then you should be able to download whatever you want - it doesn’t try to stop you.

Just to mention that Pi is loaded with companion software, not standard Raspbian image. Can I still download whatever I want?

Yes. The companion software is still Raspbian, it just has some extra code on it that tries to connect to bluerobotics equipment on startup, and passes along communication if it’s successful in doing so.

Ok, so I solved the problems but I got myself new ones. I successfully connected to my router via wifi, but I couldn’t connect to Internet, so I had to change Pi’s configuration to DHCP to connect to internet via cable. I successfully downloaded ethtool program and changed Pi parameters to 10Mbit full duplex without auto negotiation, but after PI rebooted , parameters would be set back to 100 Mbit with auto negotiation. The reason why I did all that work is that I couldn’t establish valid ethernet connection trough my 100m ethernet cable from PI to wireless router TP-link TL-WR802N. It seems like TP-link routers have some kind of issues with auto negotiation when bandwidth drops around 10 Mbit/s (because of 100m cable - btw everything works fine with shorter ethernet cable). I tested the same setup with another router (Innbox v45) and everything works fine. I wonder if anyone else had the same issues or I am missing something. Also I passed the router and connected directly to my laptop via teether and everything works fine. And yes, I changes all the possible RX-TX combinations, crossover cable and the best result I got was few good pings from TP-link to PI.

The ethtool link I provided above has a part further down the page on how to make the change persistent (" Ethtool_opt Variable to Permanently Set Ethtool Command Settings").

If you’re saying here that your bandwidth is at 10Mbit/s from a 100m tether then there’s something wrong with your tether. You should be able to get at least 50, and often more like 80 on a good tether.

Given this it seems like some kind of issue with the TP-Link router. I’m not well versed in that side of things so can’t really provide any advice beyond recommending that you use the one that’s working for you.

I finally got it!
I spent over a week combining things I could to to set my connection to 10 Mbit after reboot. In that time I managed to:

  • run desktop on Raspbian

  • run VNC to connect to Raspbian

  • use VNC to copy and paste files

  • learned that I can’t overwrite config files I wanted to replace

  • learned that vi is command to run Vim program to edit files

  • learned how to edit and save files with Vim

  • learned how to run script at boot

  • not get much sleep yesterday
    Long story short, here’s my few lines of code. I hope they will help someone someday:
    //run putty and log in to pi (192.168.2.2)

    //run sudo command to edit rc.local

     sudo vi /etc/rc.local
    

// press i key to insert text above text “exit 0”

    ethtool -s eth0 speed 10 duplex full autoneg off

//type :wq to save and exit Vim

:wq

reboot and u have permanent 10 Mbit connection!

2 Likes

Glad to hear you managed to get it sorted!
Thanks for outlining your steps here for others to use later, it’s really appreciated and helps to make the community better :slight_smile: