Home        Store        Docs        Blog

Xrotor ESCs for thruster control

(Bhargav) #1

Hello everyone.
I am facing a problem. I am using readytosky Xrotor micro 30A ESCs, min ppm =1000 and max ppm =2000, and u have changed it to bidirectional in blheli suite, the motor gives 3 beeps but doesn’t seem to give arming beep when connected to pixhawk channel 1, I am using QGC for arming and testing. What to do?

0 Likes

(Jacob) #2
  1. Check the orientation of the connector (try to turn it upside down)
  2. Check the output signal of the pin1 on the pixhawk: QGC application menu bar -> widgets -> mavlink inspector -> servo_output_raw -> channel 1
  3. Verify your settings in blheli suite, share a screenshot

What firmware are you using in the pixhawk?

0 Likes