Home        Store        Docs        Blog

Wireless Topside - Problem

So i was able to get my topside control box wireless but the one problem i’m having is that i can’t switch between a hard wire Ethernet connection and a wireless connection. i want to be able to easily and seamlessly switch between a wireless connection and a wired connection with my rov without there being hiccups. unfortunately i can just connect to my topside wireless router but when i switch to an Ethernet cable, it wont connect (even if i click forget network on my laptop for the router). does anybody know a fix for this

What IP address do you assign to the wireless and wired network adapters?

You cannot assign the same one.

1 Like

that’ what i thought when i was looking for answers online but i don’t know how to change the ip address. i am pretty sure that’s what the problem is

You need to make sure you get the same IP addresses on both situations.
How are the wiring and access point configuration of your network?

You can find videos on how to change this depending on your os I’m sure.

i connected the Ethernet cable coming from my fathom x to the access point router. the IP address for my router is 192.168.2.3 while my raspberry pi is 192.168.2.1

im kind of new to incorporating these networking devices to the rov. ho would i configure my laptop to get the same IP address?

your Raspberry pie should be 192.168.2.2
Your computer running QGC should be 192.168.2.1

Your router address doesn’t matter.

All should be on the same network mask of 255.255.255.0

Yes, the raspberry should be 192.168.2.2 and you PC 192.168.2.1
netmask needs to be 255.255.255.0 for communication with QGC to work.

Usualy you can reserve an IP for your network mac address in the router/access point. It will probably not allow you to reserve both your wireless and wired mac addresses to the same IP. I suggest you reserve the IP for your wireless mac address and set the IP on the wired one to static, this way you will still be able to connect to other wi-fis without needing to revert to a dynamic(dhcp) IP address.

Configure your router to lease a static ip address to the raspberry pi. Like @williangalvani suggests.

I would just add the same IP address to both wired and wireless but keep them disabled. By enabling only one at a time, it shouldn’t conflict (I think) and keep everything fairly simple.

You could program a software to do this if you have this aptitude.

so i have been working with my wireless control box and i have been able to control it wirelessly reliably but more and more frequently, the video wont come up on my computer. does this have to do something with the router? what can i do to get my video feed back

You need to give your computer a static lease. Check the ip address of your computer when you have issues. It should always be 192.168.2.2

im sure that its always 192.168.2.2.but how would i check to see that? one of the things i do to prevent any IP conflict is that i click “forget network” for my rov router when im trying to make a hardwired connection.

You can open the command prompt in windows and use ipconfig. It shows all ip addresses in use. Check which one is associated with the wireless connection.

The best solution for this is to reserve this IP address in your router for the mac address of your computer, this way the DHCP server will always assign it to your machine.
Assigning the IP address to the wireless interface manually is not a good idea in my experience because it will stay there when you connect to other Wi-Fi, what will probably stop your connection from working there.

i thought we had to use static ip addresses for the router. so if i changed my router static to DHCP, would that assign its own ip address to the pi and my computer. wouldn’t that affect how i communicate with my pi because it works off of a static IP. i’m not an expert with networking so is it possible give me steps on how to fix the router so it gives me video capabilities. i have the TP link nano router. thank you very much for your time and help!

I’m sorry, I may have expressed my self badly.
Set your router with a static IP Address (In the LAN side), such as 192.168.2.10
And set the DHCP server in it to reserve 192.168.2.1 for your machine and 192.168.2.2 for the Companion (this avoids that other devices get this IP).

The idea is that when you connect via Wi-Fi, the DHCP server automatically leases you the 192.168.2.1 IP that you are supposed to have.

@williangalvani is describing a ‘static dhcp lease’ aka ‘dhcp address reservation’: https://www.google.com/search?q=tplink+static+lease&oq=tplink+static+lease&aqs=chrome..69i57.2831j0j7&sourceid=chrome&ie=UTF-8