Home        Store        Learn        Blog

Wetlink with power cables?

I found the power cable between the battery enclosure and control module enclosure to be very leaky and really feel the potting process is not ideal. I ordered some wetlink 6.5 but don’t think it will work… Has anyone tried this before? Is it possible to remove the jacket and feed the two wires through the 6.5mm hole and use compression between the cables?

Otherwise would have to try re-potting… last marine epoxy we used (loc-tite) ended up cracking after repeated bends…

Hi @Amoeba, welcome to the forum :slight_smile:

Compression seals only work when there’s something to compress against (ie a smooth surface) - trying to compress against multiple cables can’t form an effective seal because of the sharp inward curves where they meet. Unfortunately that means this approach is highly unlikely to work.

Depending on your time/reliability requirements, I see your options as:

  1. Wait for us to release a suitable WLP size for your existing power cable (which I believe is planned for within this quarter)
  2. Upgrade to the BlueROV2 R3 power-cable setup, which uses two separate WLP power cables, so requires an extra penetrator position on both the battery the electronics enclosures, along with a new Power Sense Module to interface with the new 5.5mm bullet connectors (previous version uses 3.3mm)
  3. Re-pot your cable, as you mentioned. You may find our Potting Guide useful for potting best-practices, although we no longer sell the thixotropic potting compound that’s mentioned in that guide.

I use these cable with connectors and bulkheads on every vehicle I build.