Home        Store        Docs        Blog

Waiting for heartbeat from /dev/ttyAMA0 msg when connecting rsp and pixhawk


(Jacob) #62

Try swapping the rx/tx lines, verify you are using the correct baudrate, and make sure the console is disabled on the AMA0 serial interface (via raspi-config). If these things are correct, it should work.


(dusabe) #63

Dear DS Wang
I am struggling with the same problem as yours more than two months I am using RPi3 and Pixhawk could you tell me the way you did it yours , once I run the command of testing i got those number ,I am in china


The communicatory question between pixhawk and raspberry pi3
(Jacob) #64

Try to choose a different baudrate (38400, 57600, 115200), or confirm the baudrate of the serial port by looking at the SERIAL* parameters with qgroundcontrol


(dusabe) #65

Hi
thanks for your quick response I was tried to change for different baundrate but I did not expected result only for 38400 i got the one you on the picture , could you tell me what i suppose to do ?


(Jacob) #66

Please post about your single problem, in a single forum topic. It is confusing and difficult to help you otherwise.


(dusabe) #67

Thanks , actually i didn’t recognized i posted in the same forum , my issues make me to ask anywhere I found a post which is similar as mine that’s why. sorry for that but till now I am still need your help to fix my problem


(Jacob) #68

This is all the advice that I have. Try using it with your desktop and a terminal or QGC, you should be able to connect to QGC over the TELEM1 port.