Video ok but no telemetry every time i switch the BLUEROV ON

Hi All,

i just bought a BLUEROV2.
When it’s all connected and i open QGC i have the video but no communication, i can’t operate the ROV.
To re-gain the communication i have to connect the laptop (MACBOOK PRO) directly to the fathom X interface board (in the ROV or in the TOPSIDE INTERFACE) and then the communication is ok and everything back to normal. Once i have the communication i can re connect everything as it supposed to be and then it works fine until next time i disconnect and re connect the battery.
When i turn off the ROV i have to do this process again or there is nothing i can do to re establish the full connection.
Only the video is always there stable.

Any idea ?
No antivirus and no firmware are ON

Thank you

Hi @ASCHENATO, welcome to the forum :slight_smile:

This issue seems quite odd, and I don’t believe I’ve come across it before. We’re a bit unsure how your system is set up, so would you be able to provide some more information about the physical connections from the onboard computer to the topside computer, as well as the software versions you’re using both onboard and at the topside?

Given video is working fine it’s unlikely to be related to firewall issues or an incorrect IP address, but from your description it also doesn’t sound like an issue between the onboard computer and flight controller.

I spoke with the software team about this earlier and they suspected you may have multiple ethernet connections configured with the same IP address, or some other issue with your network setup :slight_smile:

Hello Eliot,
thank you for the reply.
Instead of explaining using words i made a video

please let me know if you need more info o something else.

Thank you

Thanks for the video - it was entertaining and good to see what you’re talking about :slight_smile:

I can’t see anything that’s obviously wrong with your hardware setup (it all looks fine), but I am curious about the following:

  1. In your computer’s Network Preferences, do you have more than one “Connected” network that’s configured with the IP address?
  2. Does restarting QGC (instead of unplugging hardware) fix the issue?
  3. Are you running Companion, or BlueOS on the Raspberry Pi (onboard computer)?
    • Which version are you running?
    • If Companion, does changing to BlueOS fix the problem?
  4. If you unplug and re-plug the USB connection from your laptop, does that have the same effect as swapping the ethernet-USB adaptor with an ethernet cable and then swapping back?
    • If not then my main suspicion is there may be something wrong with your USB-ethernet adaptor, although that’s a bit odd since it’s clearly working fine sometimes
    • you may wish to contact to sort out a refund or replacement for the one you’ve got

Hello Eliot,

all sorted.
I’ve updated the software and now everything is working as it supposed to be.

There are just 2 more things:

  • when i activate auto depth the trusters start to spin down very fast ( i tried in the water with the old software and the ROV was going down all the way to the seabed).
    WIth the new software i haven’t tried yet in the water but here in surface they spin and seems a bit odd to me.

  • 2nd thing is that the button to record the video in Qground is working sometimes and sometimes is not working. I know this is probably a software issue but maybe you know why and you can help me.

Thank you

1 Like

Great to hear! :slight_smile:

That’s a known issue, and there’s a discussion about it here. It may be fixed in the beta ArduSub software (4.1), but I’m not certain.

Hmm, which QGroundControl version are you using?
The current recommended version is 4.1.7 which fixed some recording issues.

We’re also pretty close to shifting over to 4.2 - just a few more changes to sort out before we make a new release that starts being the recommended version. You can try out 4.2.1 as is if you want, but likely our next recommended version will be 4.2.2 (which hasn’t been released yet) :slight_smile: