Home        Store        Docs        Blog

TSYS01 Reading error

Hi, I have a fast temperature probe I am installing in a water sampling device.

I have set up a bar30 and it works fine. The fast T is reading 0.00, however.
image

I have tried in on an adafruit m0 feather, a 328 based board and a 32u4 feather. All give the same result.

With an I2C scanning program, I find it on 0x77, so its connected correctly.

Not sure if I’ve fried it somehow? I have a second fast T that I hook up with the same result. (I could have fried them both, however).

Any help would be great.

Bill

Can you show us a picture of how everything is wired up? We test these libraries on 328 boards, so that will be best moving forward with troubleshooting.


I have the sda and scl with 5v and ground to the level converter, from there to a pullup resistor to 3.3v (10k, in the orange, though I tried 2 and 5k also), and to the Fast T probe.
The little board is just a piece of soldered breadboard with posts to share the scl and sda among the several probes i will hook up (bar30-which works with this setup, plus later a conductivity probe we are working on) and pullup resistor.

Thanks!

Hi @wje,

As far as I can tell that looks right, but it’s a bit hard to tell in the picture. I’d verify that the SCL and SDA lines didn’t get switched at some point. Did you ever operate it at 5v without a level converter?

The wires are a bit long and I2C tends to be very sensitive to that. You could try slowing down the I2C bus to reduce the chances of that. Here’s some code to do that on the 328:

// Add these two lines in "setup()" to slow I2C clock to 12.5kHz from 100 kHz
// This is best for long wire lengths to minimize errors
TWBR = 158;  
TWSR |= bit (TWPS0);

-Rusty

Ok, thanks. The same setup works fine with the bar30 so we likely did something bad to it. I’ll order another couple.

Okay - let us know how that goes! If the same problem persists we can help out.

Thanks