Home        Store        Learn        Blog

Trying to get a Fathom One online, anyone seen this beast out in the wild?

I tried to get one of these guys during the start of their Kickstarter and missed out on the early-early bird by a couple hours. Years later and I finally managed to get one. Got it a a slight discount due to “intermittent wireless connection issues” potentially caused by “some corrosion on the buoy.”

And I am discovering there is ZERO real information out there on this platform… Sure, there are a small handful of basic “hey there is this cool ROV, it takes videos underwater” type of videos. But none actually go into the nitty gritty of how it works, what is inside, etc. And there is not even the most basic startup guide or instruction manual out there.

My first problem is getting a working app for it. Supposedly there are both IOS and Android versions available. For android, I can only find v1.20 and v1.21. I can’t find any information on what the tablet or android requirements are to work with these. For IOS, I can’t actually find a link that goes to an app. I find links, but the App store locks up trying to open them. I have tried 3 different Android devices, and 3 IOS ones. The Android devices are all older, around kitkat 4.whatever. I have newer and older IOS devices though. My point is, I have tried and am not just trolling for information but genuinely stuck.

I am likely going to go try and grab a newer Android tablet in a couple hours here from Walmart or BestBuy. I need to prove this beast works, and how before I proceed with repairs, real or imaginary, and try to upgrade/modify the control system.

Ideally, I want to deal with an OpenROV or ArduSub platform. I actually have the OpenROV 2.8 dev kit on hand. But even before opening the Fathom up I can tell there is a minimal chance of getting it too somehow fit inside.

What I can tell so far. It does beep and boop when I plug the tether in. It is fully charged, and charger seems to be working good too. Connections on the wireless buoy were loose. The tether was hard to unplug as the connector on the buoy was spinning.

I opened up the buoy. The tether is terminated with a network cable end and plugged into some sort of router. There are 8 wires connected from the tether plug to the router, so I assume all those wires go through the tether also. I have not actually measured the length of the tether, but I think it is 100m. Since all 4 pairs seem to go through and there is no HomePlug type amplifier, this sounds reasonable.

The router has an additional open network port on it. No further USB connections. A reset button. There are three labels on it. PCBA-Hornet AP plus a serial number on one. Some random numbers on another, and a MAC address.

This all leads me to believe that I don’t need an actual app. Or perhaps not the Fathom specific one. If it is setup in the same manor as the OpenROV, then the configuration and all that is in the ROV anyways. I am not knowledgable on such things though and while I have a pretty good “big picture” of how the OpenROV and ArduSub platforms work, I am not sure how to translate that to getting this one connected.

What is the best way to proceed??? I suspect it isn’t as simple as plugging the tether directly into my laptop, but if that would be safe to do, I will try it.

Does anyone know what control system is inside this beast?

To their credit, when fathom went out of business, they did release a lot of documentation on the vehicle. I don’t know if there’s an official repository for it, but a search on Github found this site, which has all the CAD files as well as the source code for the Android app.

Best of luck on your quest.

-W

1 Like

Holy crap Walt that is AMAZING THANK YOU!!! Even the IOS app is in there. I think that is the whole app, not sure lol. Also not sure how one side load IOS LOL! (Google is my friend, sometimes.)

Wow there are so many stl extra goodies in that collection, buying a 3d printer will actually pay for itself.

BOM, gerbers, code, it appears basically everything is in there!!!

I grabbed a new crappy tablet from Wallys and got the software installed at least. But several hours of pain, and it still isn’t working. The “intermittent wireless connection issues” potentially caused by “some corrosion on the buoy” discount was traced down to be the most likely cause.

Now that I finally have a clear picture how this should work, the AP router in the buoy is not powering up. It took some digging, but I found another (mostly) identical router on eBay. I probably have one that would work in the computer junk drawer. But this AP powers up via the tether from the drone. Easier to mod apples, when comparing them to the apples that came out. Also, it bolts into the buoy nicely.

While waiting though, I am going to try and repair/clean the board that is in there. If that doesn’t work, I will dig through the junk drawer.

I finally stumbled across Fathom Drone’s facebook, and it actually had a good bit of information hidden in it. One video shows how to connect it to the computer to access videos on the drone. I don’t know if there is a home or controller page, but I STRONGLY SUSPECT the app is nothing more than a webpage menu list. If I can figure this out, I can use a computer, or just about any tablet, to control it.

Now interestingly enough, the Fathom’s companion computer is actually a raspberry pi. Interesting because so is ArduSub’s companion computer. ArduSub uses a flight controller, primarily the Pixhawk 1 (hard to get and flawed) but there are some newer ones that should also work. Including at least one that I have sitting in my drone drawer.

I am not sure what that autopilot does for the ROV operation that isn’t accomplished by the pi ROV shield in the sub already… I am sure there is a lot more flexibility over the telemetry layout, features, and positioning. Maybe. Maybe not. If I could install ArduSub controls into the pi and get away with just that, it would be awesome!!!

Some more poking and prodding revealed I have no power going to the topside AP. As I try to check the plug, I am having every wire on it I touch, break. I might be able to sort it without diagrams, but I already have at least one I have no idea where it goes.

The damn power wire was never actually soldered… Twisted and not tinned. And three open pins on the plug, none of those tinned either. I “THINK” I have the rest of the wires sorted for the actual ethernet connection. I am going to try and figure out if I can connect to the ROV directly by plugging that cable into my laptop. I have an address to try, but I suspect the AP being removed changes that? Networking is not my strong point.

EDIT: Nope. And connecting the tether plug and trying to access the ROV directly, didn’t work. I have bad feeling this means I will have to dig inside the ROV…

I am trying to avoid opening ROV itself up. That would potentially make this easy. But it is also buoyancy foam potted/sealed, and possibly glued too during assembly.

EDIT: I opened it up, fully polyurethane high density foam potted. Getting too much inside will be near impossible without doing a good amount of damage.

Whenever I plug the tether in, the drone powers up. So I suspect that 2 of those 3 open spots are jumpered on the ROV end of the tether. If this is true, then the third spot is the power wire. Obviously, I can also power the AP from the topside. And leaving that wire off for now should be safer anyways.

I think for the moment my strategy is to ohm out the tether cable. That might tell me something at least… I can verify my theory on the “power switch” and see how the lines run through the main tether.

EDIT: The tether cable seems to ohm straight through. And the tether cable plug ROV side is a switch, as I thought. I can turn the drone on with a jumper in pin 9 and 10. With the nose off, I can see a red light on the Pi, and a green light going on and off. Apparently this has both bluetooth and wireless built in. I am going to try and find them, but I suspect they are turned off.

The SD card is facing out, but glued in with some of the foam or something. I chipped the edge slightly trying to pull it out. Hopefully no real damage is done…