SpeedyBee F405 WING and Bar30 Depth Sensor not working

Hey, I’ve been building different kinds of ROV’s for a year now, and I’ve been using BlueRobotics parts mostly. Couple days ago I wanted a cheap alternative as an autopilot for a project of mine and decided to use SpeedyBee F405 WING, which supports ArduPilot and has hardware definitions for all the ArduPilot versions. On the official ArduSub build the sensor support is not enabled, so I tried building a custom one from the ArduPilots custom firmware builder. I added a compass thru i2c port on the board, it gets recognized, and works. But I can’t get the Bar30 to work! It works on my pixhawk 2.4.8 without a problem, but I couldn’t get any data on this board. On the full params list, it doesn’t show up as a second Baro device, the bitmask for BARO_PROBE_EXT is 768. I tried different BARO_EXT_BUS values, 0,1,6 and restarted the board everytime. But no luck. All the cabling is correct, I tripled checked it. Any suggestions on what I should try next?