Software Updates - September 14 2017

Hi Scott, I have not produced such a version for some time. The issue has been resolved in the current release software. You can find QGC in the link above, and check the 192.168.2.2:2770/system page for available updates on the ROV.

Hi Jacob,

My most recent tests used QGC 3.2.4 rev4 (GPU safe mode), with Companion 0.0.10 on the Pi, and ArduSub 3.5.1 on the PixHawk. This still produced video lag up to 2 sec. So, hopefully your comment means that it’s the Companion update that fixes the video lag issue.

So, I tried updating the firmware by manually downloading the files (this is where searching the old forums seems to be necessary, for these links). Unfortunately I am not able to use the wireless approach; due to system restrictions by my IT department, I can’t set the static IP and also have wireless activated.

Both the Companion and the PixHawk updates failed, as follows:

Companion update failure:
I downloaded ardusub-raspbian.img.zip from https://s3.amazonaws.com/downloads.bluerobotics.com/Pi/stable/ardusub-raspbian.img.zip. I connected the ROV tether, directed a Chrome browser to 192.168.2.2:2770/system, selected the zip file under “Upload zipped update”, waited while it churned through loading the 1.3 GB file, and got this message:
“validating archive
Archive does not look like a companion update!”

PixHawk failure:
I downloaded ArduSub-v4.px4 from http://firmware.ardupilot.org/Sub/stable/PX4, selected that .px4 file to upload, and here is the output:

Attempting upload from file /tmp/data/ArduSub-v4.px4
Stopping mavproxy
Flashing Pixhawk…
Loaded firmware for b,0, size: 789796 bytes, waiting for the bootloader…
If the board does not respond within 1-2 seconds, unplug and re-plug the USB connector.
attempting reboot on /dev/ttyACM0…
if the board does not respond, unplug and re-plug the USB connector.
attempting reboot on /dev/ttyACM0…

[… message repeated 5 times…]

Found board 9,0 bootloader rev 4 on /dev/ttyACM0
WARNING: Firmware not suitable for this board (board_type=9 board_id=11)

[… message repeated MANY times…]

Timed out trying to catch bootloader!
Please try again.
Waiting to restart mavproxy…
Restarting mavproxy
Complete!

Guidance please? Thanks!

Hi Scott,

Can you update companion using the SD card, like described here or via wifi, /systemCompanion Software Status → update ?

Patrick-
I will try that next- I was hoping to be able to update without opening the housing. The previous instructions led me to believe that I could use the new browser-based update mechanism using manually downloaded .px4 and .img files- is that incorrect?

That is correct.

Make sure that you are uploading a .zip file, do not unzip it.

The pixhawk in the ROV requries ArduSub-v2.px4

You should try these things first.

That’s the goal

Jacob,

I did use the Companion zip file, without unzipping. Is this the correct source?: https://s3.amazonaws.com/downloads.bluerobotics.com/Pi/stable/ardusub-raspbian.img.zip

I noticed in this post you gave a link to a “sideload” zip file for a manual update- is that needed?

For the PixHawk update- OK, will try v2. (I assumed v4 was the latest update? kind of confusing)
Thanks,
-Scott

Yes, you need to download the ‘sideload’ update file, not the OS image. Use the link in your quote.

OK, the updates succeeded using the browser interface without opening the tube, with the ‘sideload’ companion file and the ‘v2’ Pixhawk file. Thank you!

When I first fired up the ROV following these updates, there was no video lag.
However, the next step was to set up our new heavy configuration. So I loaded the heavy params file, rebooted the ROV, and now I am back to having ~2-second video lag. Multiple restarts of ROV and QGC didn’t correct it.

Please try these troubleshooting tips. Take note of the results. If you continue to have trouble contact support@bluerobotics.com to get in touch directly.

Check the camera settings are not set to 1080P, should be 720P 30FPS or there abouts or you may get lag.

@schoonerlabs We use 1080p 30fps in all of our operations without issue. This will depend on the hardware capabilities and physical setup. Most modern computers should handle it if there aren’t other applications bogging them down.

Thanks- this did help with the lag. Took it down from ~2 sec to ~2/3 sec. There is still pixelation during motion. This is on an older Toughbook- likely to be limited performance.

Hi @ScottM,
I had the same problem with pixelation on my laptop, but when i adjusted the screen down from 125% to 100% it became mutch better so you might try that and see if it helps.