ROV unresponsive after firmware update

Hi there,

Looking for some help with our BlueROV2, which is currently not working. Our ROV has been out of the water for a minimum of 6-months, however we are starting to use her again. We went to run software and firmware updates today and have ran into some problems.

The software update (1.1.1) would not run, however the firmware update (sub 4.1.0) would. As the firmware update started, the lights on the ROV turned on and the controls became unresponsive. We were unable to turn the lights off and, because the ROV was out of water, she began getting hot. The controls remained unresponsive even once the firmware update was complete. Instead of unplugging the battery, we tried to disconnect QGroundControl, thinking this would re-boot the controls.

QGC is now showing as disconnected, and we cannot use any of the controls on the ROV. We can however still see the video link through QGC. The lights are still turning on when the battery is plugged in, and we don’t seem to have any way to turn them off. Does anyone know how to reconnect our ROV to QGC? We’ve tried the usual: turning everything off and on again, using a fresh fully charged battery, etc. but this doesn’t seem to be working.

We aren’t getting any error messages on QGC, but are getting the following on the BlueOS interface:

The BlueOS interface is also showing the voltage as NaN V, and current as NaN A.

If anyone has any advice on the above, and it would be much appreciated. Thanks!

Try updating the firmware on the pixhawk again. I think that solved my problem as i had the similar challange as you.

Thanks so much for this suggestion!

We’ve tried to update the firmware again this morning, but we’re now seeing that “no data is available” under the firmware options (see below). Previously five or six options came up on this drop down menu.

Have tried to instead restore to the default, but we’re getting a message saying “cannot restore firmware as there’s no board running”. Did you run into any similar issues?

If anyone else has any suggestions, it would be much appreciated. Thanks!

Hello all. Just to update on this, we have now managed to resolve the issue with help from Matt at Carcinus (thanks Matt!).

For some reason our Pixhawk was unable to complete the firmware update to 4.1.0. We’ve now confirmed that it should be able to support this update, so not 100% sure what happened there. To resolve, and get our ROV functional again, we went through with the vehicle software update (1.1.1), and were then able to restore our firmware to 4.0.3 using the terminal in blueos.local.

Thanks for the suggestions, and again for your help Matt!

1 Like

Just to add some context here, Pixhawks are somewhat finicky, and unfortunately sometimes fail to update unexpectedly, at which point they typically fall back into a bootloader mode (with no autopilot firmware actually running on the flight controller).

If you’re running BlueOS 1.1 with Pirate Mode enabled then that bootloader should still be detected as a flashing target, which it’s then possible to try flashing the firmware of (although it sometimes requires power-cycling the vehicle first).

1 Like