Raspberry not sending signal to fathom x

Hi, eliot…Qground control is detecting pixhawk through raspberry. But, Qground is not detecting pixhawk when I use fathomX interface board and tether cable and topside fathom X. In raspberry pi’s ethernet port only green light is on and solid. Whereas, in fathom X’s ethernet port green light is on, solid and orange light is on, blinking. My guess is Raspberry pi is not sending data to fathom X, by looking at the ethernet port’s LED lights.

PS: Both power, link lights of Fathom X are “on”.

PS: Is there any changes that has to be done in raspberry pi configuration, to make it compatible with fathom x interface board.

Hi @auvproject,

The main potential reasons I can think of for this are:

  1. Incorrect network configuration
    • Does the web interface work?
  2. Some form of hardware issue
    • Can you try running a Network Test via the web interface?
    • If you bought the Fathom-X boards mid last-year and only just tried them then this may be relevant

No, as far as the Raspberry Pi is concerned the connection is just an ethernet one. The topside network configuration requires setting the IP for the correct connection (since a direct ethernet connection is different to an ethernet over USB connection), but the actual IP address being specified is the same.

  1. If I connect the raspberry pi directly to pc , web interface works and qground control detects pixhawk. But, when I use interface board web interface doesn’t work and qground control doesn’t detect pixhawk.
  2. I bought my fathom X board around august month. and my diode is named as “AC”.
    3.And, yes, I have done the topside network configuration.

Hmm, odd.

I’d recommend trying to replace/bypass different parts of the setup to see whether you can narrow down the issue. You can try swapping out:

  • the patch cable between the onboard Raspberry Pi and Fathom-X with some other ethernet cable
  • the tether (for a pair of wires)
  • the USB-B to USB-A cable between the FXTI and topside computer (those cables are commonly used by printers, and Arduinos)

If those don’t help I’d recommend contacting support@bluerobotics.com to try to find out what’s going wrong and sort out a replacement or refund of the affected part(s) as relevant. If you do so, please link to this forum thread for context, and also provide your order number (or at least rough order date) .

I have another interface board that has “5C” diode and everything worked fine when I used this one. I guess the board with “AC” diode is faulty

1 Like