Home        Store        Docs        Blog

QGroundControl and Raspberry Pi through SSH


(Ezzeddine Ayeb) #21

Hello,
Im working on ROV project using pi3+pixhawk
The Pi is already setup and flashed with the latest Ardusub-Raspbian image (12/01/2017)
All is fine and well when the Pixhawk is directly connected to the host computer (laptop) through USB compas and gps calibrations made without major troubles
But when i connect to pi from to laptop (using ethernet to usb adaptor ), there is no reaction only a red flashing light on pi and the pixhawk still off when connected via usb to raspberry pi.
Raspberry is powered by 5v 3000ma source.
Even with putty i can’t connect to raspberry.
All the settings were made as in ardusub manual.
Any help is appreciated, thanks in advance (sorry for that poor english)


(Willian Galvani) #22

If there is no ssh, it looks like the Raspberry Pi is not booting properly.
Try another usb cable/power source. Some power sources provide slightly under 5 V, and some of it can be lost in the cable’s resistance. ModMyPi, for example, ships theirs with 5.1 V and 2.5 A power sources.


(Jacob) #23

This is more than one year old. The latest image is in the instructions. Please follow there, and verify your network settings.


(Jacob) #24

Are you using Pi3B+? The image only works with the older Pi3B.


(Ezzeddine Ayeb) #25

yes, im using rpi b+ model
Is there any solutions? or should i purshace the older pi version.


(Patrick José Pereira) #26

Hi Ezzeddine,

You can check the status of the raspberry pi b+ development here:

Right now we don’t have plans to create a working image with it, but you should be able to install companion via our repository here, problem can be found though.

We recommend to use the older version.


Booting problem with Raspberry Pi 3