QGC no video stream (windows)


I can not establish video connection in QGC on notebook HP 2350p. It is not a powerful new comp but still it should be able to show video. My setup (ROV - cables) works perfectly on my MacBook but on HP with Win7 all I get is a red logo ArduSub :confused:
The connection to ROV is active with all controls and MAV-link telemetry.
Has anyone else run into the similar problem?

The attached photo is from previous install Win10, before a Win7 clean install… that did not help either :slight_smile:


We only support Windows 10, though some have gotten QGC to work on Win7. QGC installs three shortcuts, QGC, QGC (GPU Safe Mode) and QGC (GPU Compatability Mode). Please try all three shortcuts and let us know if they behave any differently.


Hi Jacob,

On Win10 it was the same. I thought that it was a driver problem so I made a Win7 clean install…

Now I have tried all three shortcuts and I get video with GPU Safe Mode but it has a 2 sec lag. Do you think that this pc is just not powerful enough?


This helped us:


Please let me know if Bo’s tips work for you, if not you can install this one instead. Video recording is disabled, and there should be no lag.

Hi Grega,

I had this problem, and after some tests, I realized that I lost the video after changing the way it would be saved. I do not know why, but I went back to the standard path and it worked normally.

If someone else lands on this thread, one of the causes for this problem seems to be launching QGC in “GPU Compatibility Mode”.
Make sure you pick the right shortcut when launching QGroundControl.

The issue can be tracked here

also meet the same problem。The first and second QGC shotcut had the error video, The third QGC shotcut can get the video,but it is very slow,so How can solve this problem

How are you/ do I get video directly on the computer screen? are you running a video grabber or is there a way to do this with out a grabber? I have tried all the settings. Is the fathom-s not setup for this?


Hi @enorton62,

Your “Video Source” Should be set to “UDP h264” and listening on port 5600.

What version o QGC are you using?

QGC version v4.0.8 on windows 10, not in compatibility or safe modes. Changed settings and still nothing. Do I need a separate USB to RCA to go between my computer and the Fathom-s?
Thank you so much for your quick response. :+1:

Hi @enorton62 ,

I’m sorry, I had not noticed that you have the fathom-S instead of the Fathom X.
In order to see the video in QGC I would do what you said and plug something like a EasyCap. Then it should be displayed as a new device in the “Video Source” Dropdown.

I don’t know what is the latency introduced by the EasyCap, though.

Thats ok, its been working for me. Now I have reason to upgrade to the Fathom-x. :smiley: :+1: Thank you

1 Like

I have a Panasonic Toughpad and all was well until some updates a couple of weeks ago. Now I have no video or connection to ping. Telemetry fine, joystick, lights, gripper all fine. I have been through the trouble shooting guide line by line but no resolution. If I ping the companion it is streaming video, just not showing video on the toughpad screen. No problem with my other laptop. Any thoughts most welcome.
After more investigation, I can get video on mission planner but not QGC. Strange.

Hi @Teggles,

Try checking if the firewall is not blocking the video ports.

With QGC open, open the Windows Resource Monitor and check QGroundControl.exe

Then go to the network tab, and in “Listening Ports”, check if port udp 5600 is “Allowed, not restricted”.

Thanks for the help, William. I have done a clean install of windows 10, reinstalled QGC and ping viewer. Followed you instructions and the ports are open. Still no video in any of the 3 QGC modes.
Another day and now when I ping the companion I appear to have lost the active services? It was there yesterday, but it still recognises the camera.

Hi @Teggles,

Can you tell us the Companion and QGC versions you are running?

Also, please double check your IP address and netmask.

QGC 4.05, downloaded from Bluerobotics site.
Ardusub 4.02
Companion 0.0.24

Double checked IP address and netmask all good.

In safe mode or GPU compatibility mode everything is good (controller functions normally - lights, manipulator, motors etc) apart from no video. I even looked at Mavlink Insp and the numbers are changing and all appears normal (apart from no video).
In the normal operating mode, everything is frozen. But when I click X to leave the program, if I click cancel on the you have active connections pop up, I get a still on the video. If I want to change pages, same procedure, click X - cancel on the you have active connections pop up and the page changes but everything on the new page is frozen.
Powered from the mains or battery alone, no change. Changed font size, no change. The Toughpad has limited options for graphics.

Well, this was definitely a new one to me.

His Windows had the “High Contrast” feature on, and somehow that caused windows to only update QGC’s window when you interacted with it (drag the window around, right click the window top bar). Disabling the High contrast mode made it work again.

Hi @williangalvani ,

We are experiencing a similar problem with a ROV we are comissioning for a client.
On our computer everything works fine. On their computer that has just been rebooted with a virgin windows 10 setup, we get all the data but no video stream.
QGC version is 4.0.5 on both computers. The network configuration is OK, the UDP stream is configured on port 5600 on both the companion and QGC (h 264 stream).
I checked the “high constrast feature”, this is off.
We unabled the windows firewall, I check on the Resource Monitor and we only have the 14550 listening port, not the 5600 which is weird.
Any idea?